Exchange - couldn't get server version

I found quite a few topics on the “couldn’t get server version” problem with Exchange. I have tried all the suggested solutions I found on this forum but to no avail.

Below I am pasting the OWA about screen to show the version of the Exchange server I am trying to connect to.

Outlook Web Access version:8.1.436.0
Exchange Client Access server .NET Framework version:2.0.50727.3623
Client Access server operating system version:Microsoft Windows NT 6.0.6001 Service Pack 1
Client Access server operating system language:en-US
Microsoft Exchange Client Access server version:8.1.240.0
Client Access server language:en-US
Client Access server time zone:W. Europe Standard Time
Microsoft Exchange Client Access server platform:64bit
Mailbox server Microsoft Exchange version:8.1.240.0
Other Microsoft Exchange server roles currently installed on the Client Access server:Mailbox, Hub Transport
Authentication type associated with this Outlook Web Access session:Basic
Public logon:No

Regards

Please help me solve this problem

Please somebody advise me on this. I emailed Paul McGregor months ago but never received a reply. I was refused help in the Pro Support. Very frustrating.

Hi, what version of eM Client are you currently using? Do you have .NET framework 4 installed on your computer?
Can you make a screenshot of the error you’re seeing? Also when the error occurs, can you please copy the content of the Log/History tab as well and post it here on the forum?

Thank you,
Paul.

Hi Paul,

I am using version 6.0.20748.0. I have in my Programs and Features “Microsoft .NET Framework 4.5.1” installed. Please find below the screenshots and a copy/paste of the log file.

16:17:17.982|017|   16:17:17.982|017| POST /ews/exchange.asmx HTTP/1.1
Content-Type: text/xml; charset=utf-8
Accept: text/xml
User-Agent: eM Client/6.0.20748.0 (ExchangeServicesClient/15.0.847.33)
Accept-Encoding: gzip,deflate


16:17:17.982|017|
16:17:17.983|017|  
16:17:17.983|017| <?xml version="1.0" encoding="utf-8"?>
16:17:17.983|017| http://www.w3.org/2001/XMLSchema-instance"; xmlns:m=“http://schemas.microsoft.com/exchange/services/2006/messages”; xmlns:t=“http://schemas.microsoft.com/exchange/services/2006/types”; xmlns:soap="" rel=“nofollow” target="_blank">http://schemas.xmlsoap.org/soap/envelope/">;
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|

16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017| IdOnly
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|
16:17:17.983|017|

16:17:17.983|017|
16:17:17.983|017|
16:17:18.522|017|  
16:17:18.522|017| HTTP/1.1 200 OK
Pragma: no-cache
X-OWA-Version: 8.1.436.0
X-UA-COMPATIBLE: IE=EmulateIE7
Content-Length: 8374
Cache-Control: no-cache
Content-Type: text/html; charset=utf-8
Date: Tue, 09 Sep 2014 14:17:08 GMT
Expires: -1
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET


16:17:18.522|017|
16:17:18.523|017|  

16:17:18.523|017|    
16:17:18.523|017|   
16:17:18.523|017|    
16:17:18.523|017|  
16:17:18.523|017|  

16:17:18.523|017|  

16:17:18.523|017|  

16:17:18.523|017|   Microsoft Exchange - Outlook Web Access

16:17:18.523|017|  

16:17:18.523|017|  

16:17:18.523|017|  
16:17:18.523|017|   
16:17:18.523|017|  
16:17:18.523|017|   
16:17:18.523|017|  
16:17:18.523|017|  
16:17:18.523|017|   
16:17:18.523|017|  

16:17:18.523|017|



16:17:18.523|017|

16:17:18.523|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
To use Microsoft Outlook Web access, browser settings must allow scripts to run. For information about how to allow scripts, consult the Help for your browser. If your browser does not support scripts, you can download Microsoft" rel=“nofollow” target="_blank">http://www.microsoft.com/windows/ie/downloads/default.mspx">Microsoft Internet Explorer for access to Outlook Web Access.


16:17:18.524|017|


16:17:18.524|017|

16:17:18.524|017|  

16:17:18.524|017| " rel=“nofollow” target="_blank">https://webmail.melitamarinegroup.net/owa/ews/exchange.asmx">;
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|



16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|


16:17:18.524|017|


16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|


16:17:18.524|017|
16:17:18.524|017|



16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017| Security
16:17:18.524|017| ‎(
16:17:18.524|017|
16:17:18.524|017| show explanation
16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017| hide explanation
16:17:18.524|017|

16:17:18.524|017| )‎
16:17:18.524|017|
This is a public or shared computer
Select this option if you use Outlook Web Access on a public computer. Be sure to log off when you have finished using Outlook Web Access and close all windows to end your session.
This is a private computer
Select this option if you are the only person who uses this computer. Your server will allow a longer period of inactivity before logging you off.
Warning: By selecting this option, you confirm that this computer complies with your organization’s security policy.


16:17:18.524|017|



16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|
Use Outlook Web Access Light
The Light client provides fewer features and is sometimes faster. Use the Light client if you are on a slow connection or using a computer with unusually strict browser security settings. If you are using a browser other than Internet Explorer 6 or later, you can only use the Light client.


16:17:18.524|017|



16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
User name:
Password:


16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|


16:17:18.524|017|



16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|



Please enable cookies for this web site.

Cookies are currently disabled by your browser. Outlook Web Access requires that cookies be enabled.

If you are using Microsoft Internet Explorer 6 or later, open Internet Options from the Tools menu. Click the Privacy tab, and then click Sites. Type the address for Outlook Web Access into the field, click Allow, and then click OK to save your changes.




16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
Connected to Microsoft Exchange
© 2007 Microsoft Corporation. All rights reserved.

16:17:18.524|017|

16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|
16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|

16:17:18.524|017|   
16:17:18.524|017|  
16:17:18.524|017|  

How did you setup the account, did you use the automatic setup? Can you please also make a screenshot of your account settings from Tools > Accounts > Your Exchange account > Mail, Calendar, Contacts tab?
Are you using Exchange version 2007 SP1 on your Exchange server or later?

Thank you,
Paul.

Thank you for your continued help. Doesn’t my first post indicate the version? It is copy/paste of the about screen in OWA. Anyway, as far as I know it is Exchange 2007 SP1.  I did not use automatic setup, I had set up my account by clicking on New account > Mail > Exchange. Requested screenshot below.

Can you please try to setup the account using the automatic setup? It seems like you have not setup the server address correctly, since I can not see the login window using this address.

Thank you,
Paul.

Screenshot of the automatic setup below. I am sure that the password is being entered correctly. The username is different from the mailbox name, that is, it is not d.zahra but darren.zahra however there is nowhere I can enter the username in the automatic setup.

Hi again, I understand, sorry for the misunderstanding, if you’re using domains and different username from your email, you have to use the semi-manual setup under the mail tab as you did initially.
If you’re using a company email, can you make sure you’re using the correct server address for the setup, possibly provided by your IT department?

Thank you,
Paul.

The company is insisting that the address to be used for EWS is the same as that used for OWA: webmail.companyname.net. I can see that eM Client is in fact making some sort of contact with the Exchange server as when I purposely enter the wrong password it asks me to re-enter it.

Are you using a firewall/proxy software on your computer or in your network or possibly an antivirus software with email protection?

Thank you,
Paul.

I use Microsoft Security Essentials which I disabled for troubleshooting this problem. Windows Firewall is disabled as I sit behind a NAT.

Can you please go to Tools > Settings > Advanced and turn on Exchange Web Services logging for the problematic account?

  1. Save the settings
  2. Restart the application 
  3. Repair your account (Right click the account in the left sidebar and select Properties > Repair and click on the “Repair” button.
    When you do this please go back to the advanced settings window and click on “Send logs” and send the logs to mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul.

I can’t do the repair because the account is not being listed in the left sidebar…

Hi again, can you please go to Tools > Accounts > Your Exchange account > Mail, Contacts, Calendars and edit the Server address so instead of http://…. it contains https://…. ?

Thank you,
Paul.

Already https:// as you can see in the screenshot I posted earlier

Hi again, can you please send me an email to mcgregor@emclient.com with a reference link to this forum topic?

Thank you,
Paul.

I did so last Wednesday, will do so again. Since then I have bought 2 licenses so I now expect this problem to be settled