Errors during synch with Yahoo! mail accounts

Errors with Yahoo! Mail accounts keep popping up, saying that settings are wrong, passwords or usernames are wrong (they aren’t! I’ve checked them thoroughly a couple of times!), or that it isn’t authorized to download settings. Yet when I click ‘Ignore’, the e-mails are downloaded normally.

This happens due to the Yahoo’s CalDAV servers. If you do not use your server calendar, you can easily get rid of the error messages by disabling the calendar service in your account settings.

I don’t use the calendar service from Yahoo! so it was disabled from the start. I only synchronize Mails and Contacts. In the mail accounts settings, when clicking on ‘Diagnostics’, IMAP and SMTP work fine (it shows ‘OK’). So I don’t get why the errors keep showing up. :frowning: Most of the time, I just click ‘Ignore’ when the errors display, but the ‘!’ behind the account name and the problem window keep popping up and that’s really annoying.

Here is what the error says

This is a slightly different case - it is caused by CardDAV server so I recommend you to disable “Contacts” service in the account settings - it should help.

Don’t know how to do that. Not easy to find.

Hello,

Tools - Accounts - your account - Calendar and Contacts (or contacts alone) tab, scroll down and there is “Enable service” box.

regards
Jan

I do not use the Yahoo calendar and contacts and I can receive and send emails. I am gradually moving away from Yahoo to Hotmail which does not give me any problems… I no longer have the window popping up and telling me the user/password is wrong!

As it is, this is the only possible solution at the moment.

Still doesn’t work.

This only happens with Yahoo. Why can’t yahoo just make an email client?

This is not about email client, this is about their authentication servers…

We hope that they will address this issue at least in foreseeable future as it is hard telling users still the same that this is on their side and only thing we can provide is some workarounds…

with regards
Jan

I know. Yahoo likes to break their mail every 15 months or so. Their calendar has never worked with my other email client and I haven’t bothered to try on the iPad since Gmail calendar works so well. Problem is, my Yahoo email address is my favorite because of subfolders I can create. I even pay the $20 per year to get rid of the ads.

By the way, the “enable service” switch was not working for me so I deleted the account and then re-created it. But this time I unchecked calendar and contacts during the creation process.

Hello,

I am not sure about Yahoo’s subfolders since I use it only for testing purposes, but I know that Outlook.com can make subfolder which are being synchronized over email clients too.

with regards
Jan

Can you have a local calendar and NOT sync with server calendar? (when you say settings, can you say eM settings or yahoo settings - thanks - fyi I have not been able to click on and access yahoo settings in months) Thank you.

When you disable the service, it unchecks “enable account” in the general tab

Hi, can you please be more constructive with the description of the issue?
What unchecks “enable account” are you having some issues with the settings? Not completely sure how is this related to this post.

Thank you for clearing this up,
Paul.

It’s about “disabling the service”.  When you uncheck “enable service” on the calendar tab, it seems to also uncheck “enable account” on the general tab.  I keep having the cardDAV error pop up as well.

Account should not be disabled when disabling calendar and contacts services, but if you’re seeing these kinds of authentication errors, please go to your account settings and select Calendars.
The CalDAV URL will contain /users/username@yahoo.com/ part at it’s end. Please change the CalDAV and CardDAV URL (under Contacts) to a format that does not contain the @yahoo.com part:

/users/username/

This way the authentication errors should be disabled if you’re using identity credentials.

Hope this helps,
please note this topic is over a year old and does not contain any relevant information regarding this issue.

Paul.

I was having the same issue described and made the suggested changes.  On my test email, there were no error messages.  Thank you so much!!!