.eml attachments don't work

Can you please go to Tools > Settings > Advanced and turn on Exchange Web Services logging and use the repair function again.
When you do this, please go back to the advanced settings window and click on “Send Logs” and send us the Logs.
Also please attach one an exported email containing the corrupt .eml attachment and include a reference a link to this forum topic.

Thank you,

Hi Paul thanks for help! tomorrow  i will go to my client and i will do it.

Hi Paul. I sent the email with the logs. Thanks again for the support.

Hi, the logs received are IMAP but it seems to be an Exchange account, can you setup the account as Exchange, that might resolve the issue…

Thank you,

This problem has just returned for me. I received an email with two attachments from a sender who has an Exchange account. Both attachments show as zero bytes. In Outlook and on my Android device the attachments appear properly.

Hi again, are you able to replicate the issue? Does it occur with every single email or was it a problem with this single email?

Thank you,

Right now it is occurring with two separate emails received over the past few days, from two separate senders. Interestingly, if I hover over the attachment icon I can see a preview of the email that is attached, but when I try to open or save the email attachment I get an error message that says “Error occurred when saving the attachment: Attempted to divide by zero.”

Can you please make a screenshot of the error? Also could you go to Tools > Settings > Advanced and turn on IMAP logging for the problematic account (if this is an IMAP account)?

  1. Save the settings
  2. Restart the application
  3. Right click the folder (inbox) where the emails are located in and Repair the folder
    To repair a folder right click the folder and select Properties > Repair and click on the Repair button.
    If the issue persists go back to the advanced settings window and click on “Send logs” and send the logs to [email protected] with a reference link to this forum topic.

Thank you,

I can’t seem to post a screenshot here, but I have emailed one to you.

Here is something else interesting. Per your post on this subject about 3 weeks ago, I created a new email to you and attached a copy of the email with the “0 bytes” attachment that won’t open or save. As attached to the new email, the original email and its attachment both look, open, and save just fine!!!

Hi again, I’m a bit confused by this situation at the moment. After you tried to send me the data did the issue resolve itself? Or is it connected to adding the email as an attachment?
Are you still using the 20617 version of eM Client? If so, can you please update to this version: http://www.emclient.com/dist/v6.0.20698/setup.msi

Thank you,

I have same problem: if someone attach an .eml file to an email, eMClient show it empty while I see it correctly via WebMail

Bruno, can you send me the email in which this eml shows empty?

In eM Client right-click on the message and choose Forward as attachment to [email protected]

For what it’s worth, this issue appears solved for me in recent versions.  I just went back and reviewed four year-old emails that would have prompted me to report this issue in the first place, and the .eml attachments displayed properly.  I’m currently on version 7.1.31849.0.

I was on, updated to the latest but the problem remains


Gary I’ve sent you one of the email with the .eml attachment that have that problem


In this case the eml is empty. It only contained two lines:

MIME-Version: 1.0
Content-Type: text/plain

Does this happen for all eml attachments, or is it only from one person?

I sent you an attached eml file, so see if you can open it.

Believe me on Web Outlook, I correctly see the eml attachment

With the one you sent me, I see an empty zero byte attachment

While on Web Outlook, I see correctly your test mail:

That was the problem I used to have, and it happened for all .eml attachments.

This is how I see your test mail on eM Client: