Emclient not closed correctly

Almost everyday when I open Emclient I receive the window that says “emclient was not closed correctly—several checks need to be made…” It makes no difference if I use menu-exit or X-out. Is there a way to fix that?

What version of eMC are you using?

shows version 8.2.1473

IMAP or POP3?
When you close eMC, how long after do you power down or put the pc to sleep?

How do you close emclient, Menu exit or x in upper right? or ??

How do you close your computer?

I believe he already told us…

I shut down as soon as the em window disappears. The errors on the log are all IMAP with only one sync error

Have tried both…no difference. I use SHUT DOWN to close computer

Try pausing about 1 minute before shutting down the computer to give eMC a chance to update.

I have the same problem and I start to hate it …
I usually just shutdown the computer and I expect EmClient to block shutdown operation until it’s properly saving all its databases (or whatever) so that when windows is shutdown emclient is clean … But somehow … this is not working. Every time I start windows, EmClient is checking databases …
This CAN BE SOLVED by EmClient developers !!!

@adynis,

Perhaps, in the meantime, you can try my suggestion above and see if it makes any difference. In the last year I have only had one instance of eMC having to go thru an “integrity check” when starting the app after a windows issue while eMC was open.

I believe you have scouted out the problem. Last night when I was ready to shut down, i closed eMC and waited for awhile before I shut computer down. This morning when I opened eMC, it went straight to opening with no checks required and no operations error page. My wifi is so slow and response to almost everything is delayed so poor eMC doesn’t have time to receive msg and act on it before cmptr is shut down. Thanks for the help shedding light on the problem!!!

Thanks @sunriseal for the suggestion.
As @jemster2 commented, it might work, but for me this is not a solution. It’s a “no go” to close eMc then wait 1 minute and then shut down computer.
As any other software which is able to block the shot down action (e.g.: leave an unsaved word and then shutdown computer), eMc should not allow windows to shutdown until all internal tasks are finished. the target is that I select Windows Shutdown and that’s all. This is my wish/expectations. I searched for some options to make windows wait for all programs to close before initiating shutdown, but no option helped me …

If my suggestion works I fail to understand why you would not use it in the interim while waiting for developers to work on your “wish/expectation”. You must be a gluten for punishment since you state “I start to hate it …”.

Best of luck in your pursuit.

Unfortunately this is your OS that is forcibly closing eM Client.

You don’t need to wait 1 minute. Just close eM Client, and then shut down Windows. See if that works. Otherwise you need to contact Microsoft and ask them how to disable the OS from forcibly closing applications.

Other applications will not be affected in the same way, unless they are also using SQL databases. What happens when you close a SQL database, is that the temporary data is written back to the main data files. When the OS interrupts that, on the next restart of eM Client the database needs to be checked to ensure data integrrity.

viernes 08 octubre 2021 :: 1147hrs (UTC +01:00)

Hi @adynis

I agree with @Gary regarding shutdown, however, what is a major factor when considering the time taken with SQL database write back before closing your system is the size of the database and the overall capability of your system. The greater the performance, amount of RAM etc the quicker the write back.
It is not an eMC fault it is the ‘nature of the beast’ with a SQL database; first close eMC then your system and you should not have a problem.

¡Saludos desde la soleada Valencia en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

It is a problem of EmClient to close its windows before it shutdown all background operations.
It is very bad practice to rely on user behaviour.

Properly EmClient should:
a) close instantly - best option, SQLite database close within fraction of second (i worked with it, it does even with heavy tens of GB db),
b) show closing popup with explanation why it does not close yet, which closes when background operations finish.

1 Like

viernes 08 octubre 2021 :: 1255hrs (UTC +01:00)

Hi @Sylwester_Zarebski

I don’t know if your post was for my benefit as it was not addressed to anyone, however, you are entitled to your opinion with which I do not agree.

¡Saludos desde la soleada Valencia en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

That is the issue in that it is not eM Client that is closing itself, but the OS that is effectively just pulling the plug on the application without warning or waiting.

It takes just a second or two for the SQL database to be closed correctly. But this can be delayed if the database is on a slow mechanical hard disk, or on a USB or remote storage location.

Please try this:

  1. Close eM Client.
  2. Open task manage and make sure that eM Client is not running. If it is, that is another issue.
  3. Restart Windows.
  4. Start eM Client.

What is the result?

Read once again:

When window is closed, executable should exit as well, but it is not the case. I’ve have seen this behaviour few times, even if my computer is mostly high end.