emClient Mac - silence email deletion 'pop' sound

I have emClient 9.2.1628 for Mac configured to confirm email deletion. When I hit Delete, I get a ‘pop’ sound alert as the confirmation dialogue appears.

How can I stop that sound?
I would be quite happy to silence any and all sounds if that’s another option.

Have crawled all over the Settings but can’t find an option to achieve what I want (also searched here in forums but no answer found).



Unfortunately you can’t remove the sound.

However, you can disable the confirmation popup, then you won’t get the sound either.

Just click the Don’t ask me again option in the popup.


Thanks for the bad news! At least I know I hadn’t missed anything.

I enabled the confirmation because on 3 or 4 occasions, I had pressed the delete key to delete an email and 10, 20, 30 emails were rapidly deleted. As if the delete key had stuck. But it kept going until I moved focus.

Pretty sure there’s nothing wrong with my kb as I’ve never seen that occur in any other app.

Will have to decide if I want annoying sounds or a risk of unwanted deletions.

Must say, I’ve never before encountered an app where the sounds were not configurable.
I’m not going back to Outlook though :frowning:


I had pressed the delete key to delete an email and 10, 20, 30 emails were rapidly deleted

mmm this issue does sound keyboard related.

I would test with another cheap eg: USB wired keyboard to see if this is a sticky key problem as I also use eM Client for Mac and never get this issue with my wired or wireless keyboards.

I agree it does sound like a suspect kb, but I’m unsure. It’s a nice mechanical Filco that I’ve used for a few years without any other issue.

But I’ve realised the unwanted (to me) ‘pop’ sound happens with a number of emClient events, not just mail deletion.
Perhaps a future update will include such a config setting.