eMClient doesn't synchronize/refresh at eMClient startup since update

Since I updated to version 9.0.1708 eMClient no longer synchronizes or downloads/refreshes emails when I start up the App. It used to do this just fine. I can click the “Refresh” button and it downloads the emails and then downloads at the specified time intervals in settings. It just doesn’t download/refresh when I start the App. Using 2 different gmail accounts. It worked great before I updated. Thanks.

Is this activated?
Menu > General > Synchronization > “Synchronize items at startup”

Yes, it is activated.
Current Details:
Issue Date:7/27/2021
License for Version: 9
Number of Devices: 1
License Type: Free

Also, Synchronize items at startup is checked.

Also, Synchronize items at startup is checked.

I would try “unchecking the option” to synchronise on startup and then save settings and then close and open eM Client. Then reopen eM Client and enable the synchronize on startup again and again save settings and close and reopen one more time again to see if that fixes it. Could just be that option needs toggling.

Failing that backup eM Client via “Menu / Backup” and once backed up uninstall the program and “don’t delete the database” when asked on uninstall". Then re-download and reinstall that same version from the version history page and see if that fixes it


I did all of the above. Still no luck on downloading emails on App startup. If I click refresh a few seconds after eMClient starts then it successfully downloads waiting emails. It just doesn’t successfully download waiting emails right at startup. Actually, it behaves like it tries to download the emails at startup before everything is ready to go. Maybe my computer is too slow. Other then that, everything seems to be working fine. It successfully checks and downloads waiting emails at the specified interval, it just doesn’t succeed on the app startup. Maybe my antivirus software (BitDefender) is checking and interfering with something when the app starts. This is not a bigee because everything else seems to be working. It might work if eMClient waited a few more seconds after the App startup before trying to initially download the emails.

Then try turning the antivirus software OFF and re-start eMC

1 Like

I turned off my antivirus and nothing changed. It still didn’t download emails at eMClient startup. Everything else seems to be working fine. I am just going to live with it and hope that some future update fixes it for me.