EmClient Contacts not Synch'ing with Google Contacts

Just happened to notice that my contacts which I keep udpated on my Em Client (Mac) haven’t sync’d to my Google Contacts.
Very frustrating issues, given that I have a Pro license. Using v9.2.2144.
IMAP: 993, Force SSL/TLS
SMTP: 587, Force SSL/TLS

Appreciate your help. Thank you

You need to have the contacts in one of the Google Contacts folders in eM Client. Normally that is My Contacts. If they are in another account folder, or in Local Folders, they won’t sync with Google.


If the Google folders are not visible, then you may have disabled the service. Go to Accounts and click on the General tab for the Google account. Scroll down to Services and make sure the Google Contacts service is ticked, then click on Save & Close.

If you have everything as above, and it is still not syncing (means you can’t see the contacts in the Google Contacts web page) maybe there is an error. You will find that in Tools > Operations > Log tab. Look for a Google Contacts error.

PS. You gave your email settings above. Please note that the security policy for your IMAP setting is incorrect. It should be 993 = Use SSL/TLS on special port (legacy)

1 Like

Thank you Gary. I changed the IPAM setting back to yours but still no dual-way synchronization. Very, very frustrating and many hours wasted.

I tried eM Client Deduplicator but it doesn’t seem to be doing the job. How can I transfer all my eM CLient contacts to my Google Contacts and use Google’s Merge & Fix to get rid of all the duplicate that eM Clients somehow created?