emc7 cant load database from correct location

I changed the location of the large data store and the program lost all my contacts and settngs from (allegedly) c:\users~username\AppData\Roaming\eM Client. They are still there but it doesn’t read them and I can’t seem to import them. I copied all the files from the original location of the large storage but did not touch the appdata stuff. Why would I?

Did you change the location back to the original one?

I have a comparable problem. Changed the database and it came up with a new account. I tried it another time and again it came up with a new account, trying to install the server address parameters etc. I do not want a new account. What I wanted it to do is open the database from a new location, it being logical address Y: on my NAS. Help! How do I open my original database? It is there on the new address, which seemingly is acknowledged by the new account… also replacing the file to a location on the c:\drive did not help. I got a message that the app did nod have an allowance to open the standard database location due to insufficient rights…

I solved it by copying my old settings files over the newly created ones and fortunately that did not blow up.

I think what happens is that you do the change in emc and it records it somewhere. Then you shut down emc and move the files into the new spot while it’s off, which is a reasonable thing to do. 

Then when emc starts it sees that the database has moved and over-writes some portion of it with empty files, scrubbing your copy. This is my guess and if it’s true that is pretty dumb.

It’s something like that. Then their import function doesn’t seem to understand that there is a database in the original location which is how I was trying to fix it using the interface. That was the prompt for my original post.

I opened two file explorer windows side by side to look at the file details and saw where there were some size and date differences. So I tried moving some files that looked pertinent which were larger than their newly created versions and bit by bit I reconstructed my original settings. Move them as a group if you do this, meaning move filename.* which is all different extensions at once. Otherwise the database may get confused.

They either need to fix this or amend the move instructions. IMHO


another update: I was helped by Anthony from eMClient. It turned out that my copying apparently went wrong, and I copied the eMClient directory into another one, don’t ask me how…  So just to be sure: copy your original database directory as a whole and copy that to the desired location. The easiest way to do that may be using two explorer screens, so you can copy it directly by moving it from one screen to the other. I am a happy customer again!