eMails with multiple recipients slow to send

Having an issue with emails with multiple recipients. The more recipients, the bigger the problem. When I hit send, the whole program just hangs. A few seconds for two-five recipients, but when I have 100 BCC’s it can take several minutes to send,

Been like this for quite a few releases at this point, I was hoping it would get fixed but it seems a persistent problem.

Could possible be an optional installed eg: Antivirus email outgoing mail scanning checking in the background for any viruses on the way out in eM Client.

Thanks for the reply, but I do not think that is it. I’ve been using Eset and eMclient for many years, plus my first install is eMclient and it usually takes me quite a few days before I get around to installing eset.

I’ve been using Eset and eMclient

I would for a test though just to rule it out, to completely disable ESET (Internet Security) and then close and reopen eM Client V9 and see if it makes any difference.

Failing that check you have the latest version of eM Client for Windows or Mac. Latest versions of eM Client V6, 7, 8 & 9 are on the version history page.

Suggest to be using at least “the latest V8” with Windows 10 or Big Sur OS 11.

If you do upgrade, backup first via “Menu / Backup”. Then once backed up, close eM Client and d/l the update and install the update. L

Btw What version of eM Client are you currently running and do you have Windows or Mac and what version OS is it.

I get the same issue, the more recipients there are the slower it is to finish the send, even with a simple text message. I have no 3rd party security software.

I disabled mine and got the same thing. I do notice that it seems to get worse the longer I’ve had emclient up and running. When I first restart it can send a multiple recipient fairly normally but if it’s been up a couple days and I send to ten recipients it can take a full minute.

I had a similar problem with V9 until today. It was an issue with updating the Recipients History.

Try disabling this function, and see if there is any difference.
You will find the setting in Menu > Settings > Mail > Compose > Recipients History. Just untick the option and click on Save & Close.
Steve

Try disabling this Recipients History, and see if there is any difference.
You will find the setting in Menu > Settings > Mail > Compose > Recipients History. Just untick the option and click on Save & Close.
Steve