Emails not appearing in Inbox, just All Mail

Unfortunately a large number of new emails are not shown in my Inbox: they are only shown in All Mail. This was not the case but has started recently. Any suggestion on what Gmail or eMail settings effect whether they appear in Inbox would be very welcome.

Check in eM Client under "Menu / Rules if you have setup any previous rules that might be moving emails (to other folders) which then will show in Gmail “All Mail” folder but not in the Inbox.

If no rules setup, then check in Gmail filters online, via “Settings / See All Settings / Filters and blocked email address’s”.

If the emails are showing all ok in the inbox (online in Gmail), then suggest to run the Gmail repair in eM Client to re-sync your folders. “Right click” on the “All Mail” folder under your Gmail acct, and click “Properties” at the bottom. Then click the “Repair” tab at the top and click “Repair”.

First, thakns very much for the quick response, I do appreciate it.


  • checked Rules & confirmed none in place only 3 based on specific email addresses are moving emails to other folders (and confirmed that the missing emails are not shown in those specific folders)
  • checked Gmail Filters: nothing redirecting emails from Inbox & deleted the 2 there just in case
  • Ran Repair: took a while but completed and made no difference

One thing I do see is the emails in All Mail do not have an Inbox tag - a good reason not to appear in Inbox. The same issue is visible in Gmail. Any idea how they get that tag and how/what could be removing it?

Thanks again.

Yes, eM Client can only sync what is on the server. If the messages doesn’t have the Inbox label in Google, it can’t be displayed in Inbox in eM Client.

@garyb2305 Also check that in Gmail settings (online) that you have set Inbox type - “Default”.

Just checked and confirmed that it is set to Default. Not the right forum for it I know but do you have any idea how Gmail assigns Inbox labels/tags to incoming emails? Ideally assign them all new emails until I get to deleting/moving them.

As far as I know with Gmail online, all incoming emails (apart from detected spam) is automatically assigned the Inbox label, unless you have filters or rules setup either online or in mail clients.

Suggest to check if you Gmail online “Account Permissions” / (Third party apps) has allowed / setup any other email client app / program which might then be possibly interfering or modifying the incoming Inbox label - . If there is is another mail app or program, try removing access to test in Third Party Apps and see if your incoming email then shows in the Inbox.

Also check in Gmail online “Settings / Forwarding and POP/IMAP” to see if any forwarding has been setup.

I checked and removed some of the app’s with Gmail access - altho none of them looked likely it was a good thing to do regardless & thank you for that. 2 other things:

  1. I now see the emails I expect to see in my Inbox. Unfortunately I cannot say which of the changes made fixed the issue but it looks like it has been fixed which is great.
  2. I have changed the startup folder to be All Mail so I now see everything regardless of flagging.

With both the problem looks like it has been fixed and my email life is now a lot better :-).

Thanks VERY much for your help with this. I really appreciate your suggestions & making more when the first weren’t successful. Hopefully I can return the favor someday.

Have a great week,


1 Like