Emails going into Unread Folder - not showing up in Inbox

Some of emails will show up in the Unread folder, but nowhere else. Once I have read them, they then completely disappear. They are not in my inbox or trash. I am not sure how to fix this. It doesn’t happen with every email that comes through, but a good portion of them. 

I’ve noticed that some of my YouTube incoming emails that come to my Gmail account show up in the ALL MAIL portion under that address folder but NOT in the All Inboxes  folder under Smart Folders.  No clue why that is happening.

This has been happening in Version 7.1.30794.0 Pro. 

Other than that I like version 7 much more than 6. 

Ken, in the Unread Folder, if you choose Menu > View > Layout > Message Panel Off, you will see among the columns one called Folder. That will tell you in which folder the email is stored.

Obviously once you have read them, then they will no longer be in the Unread Folder, but this will enable you to track them down before being read. Once you know where they are, and if they are not supposed to be there, let us know and maybe we can see why that is happening.

Hi mustangace.

All Inboxes is a special folder that displays the contents of all inboxes. Only inboxes - not any of the sub-folders. If your missing YouTube emails are not in the Inbox, they will not show up in All Inboxes.

All Mail is a GMail folder that has all mail, including the Inbox, all folders and sent mail. So anything that you can’t find in All Inboxes, will certainly be in All Mail.

Make any sense?

After seeing Mustangace’s issue and trying to resolve it with your instructions… it seems as if we are having the same issue. It is going into the All Mail Folder, but not into the Inbox folder. Not sure why this is just now an issue as we have been using eM client for 6 months now… and out of the office only one is having this problem. 

Well, I think I may have fixed it… seems as if it is a problem with gmail. I went into the Settings > Inbox > Selected Override Filters - Include important messages in the inbox that may have been filtered out… Hit Save Changes… Did a few test emails and it seems to be working now. 

Gmail emails exist only in the All Mail folder. Well, except for spam and trash. It is only when they have the Inbox label that they will appear to be in the Inbox. The label is assigned to all new incoming email, except for those designated as spam.

So somehow they are losing the Inbox label.

Any Rules configured in eM Client to set categories to none?

Any filters setup in GMail?

Makes perfect sense, but not what I want nor what I had intended to have happen. 

You see, I upgraded from eM Client 6 Pro to eM Client 7 Pro when I built my new computer. I actually installed 6 first to make certain all folders and saved mail was restored to what it was on my older computer.  Only then did I do the upgrade to version 7. I wanted to make certain everything appeared properly and worked the same first before the upgrade (which I had purchased some time ago, btw).

ALL mail appeared in the inbox in version 6 on my old and new computer (excepting my pre-selected junk mail, of course) and that only changed with version 7 installed.  Why?  I’m clueless, but I’m going to try the fix suggested by Keri Bonassin in her message.

Thanks for your work in finding a solution, Keri!

Apparently this works in/for eM Client 6.  I can’t find the same or similar setting for eM Client 7 under Menu>Tools>Settings.  There is no  Inbox item, and so, no Override Filters.  I checked in several other places but could not find such a function in version 7.

GARY CURTIN :  Suggestions for finding Override Filters in version 7?

It is a setting changed through the GMail web interface, not eM Client. :slight_smile:

Oh, okay.  Will give that a try.  Thanks.  :slight_smile:

Yup, found it in GMail and changed it according to Keri’s suggestion.  Hope it works to correct the problem.  

Appreciate both of your help with this.  Thanks!

Gary Curtin :

Nope.  Gmail’s Setting>Inbox>Selected Override Filter - Include important messages in the inbox that may have been filtered out did not work for me. 

My Gmail YouTube video linked emails still avoid the  eM Client 7.1 Pro ** Smart Folders All Inboxes folder_ _and can ONLY be found under my Gmail account’s All Mail folder.  **

How can I get all my Gmail to show up in the All Inboxes folder in eM Client 7?  Any other suggestions??  Perhaps something else needs changed in Gmail

It’s strange that I didn’t have this problem before when I was using eM Client 6 (about a week or so ago before my upgrade to 7 - and I’ve been using 6 for over a year or more).

The fix Keri suggested in Googles Gmail settings may be working, kind of… 

I am getting some YouTube video links now in the eM Client All Inboxes section but others still only show up under my Gmail account setup in eM Client’s ALL Mail folder.

I’m beginning to think this might have something to do with when one has subscribed to YouTube content:  

  • If subscribed to YouTube video after  eM Client 7 is installed it seems to go to All Inboxes

  • Before eM Client 7 is installed, they go to Gmail’s ALL Mail folder in eM Client ONLY

That’s my best guess as to why I get some in All Inboxes and others only in ALL Mail folders.  So, I might need to unsubscribe and then subscribe again, it seems.

Maybe what Keri described only applies to new messages, so the old ones will not be affected.

If you open the web interface for GMail, and select all the YouTube messages, then choose Move to Inbox, that should solve the problem with the old ones.

Will try that, Gary.  Seems like it should work. Thanks!

Well, it was working for a while and now it seems to have stopped working and went back to its old ways… Not sure where to go from here. 

One thing that I read since this thread began is that Gmail will skip the Inbox for emails that have smart labels like Promotions, Social and Updates.

You can Google how to disable this feature in Gmail.