Emails from Alias regularly end up in spam

Hi everyone,

I’ve become an emClient pro user a good year ago. Since I work freelance with many different clients, I ended up making aliases for every client ([clientname] to send emails; incoming emails as replies going to [clientname] are sorted by the mail server into main+[clientname] so I get a correct folder sorting system. My issue, though, is with outgoing emails from aliases.

Frequently, these emails either seem not to arrive at all (though logged as correctly sent by my mail server) or end up in spam. My hoster assumed it had something to do with the emails’ headers, yet according to them those look okay. Sometimes, they get “X-SPAM” values added that designate the e-mail as not spam, apparently.

I’m a little lost here. I can’t have spam folder issues with manual whitelisting for every customer I begin working with. Does anyone know of anything I can do about this please?

Thank you.

Best wishes,
Tom aka Strike

Some servers think the message is spam if you have used a signature.

You could disable signatures and see if there is any difference.

If that works, consider including the signature in a message template instead, as this will not add the offending signature tag in the HTML.

Hi Gary,

thank you.

I don’t use any signatures at all. It’s quite obviously linked to aliases as e-mails sent from “physical” addresses in the same domain arrive perfectly. There must be something in emClient headers of alias mails that trigger most servers to be overly cautious. I really need to use this feature or I’ll have to find a different email client :frowning: Would you or anyone else know any other possible solutions?

Thank you!

The headers may be different depending on your provider.

If you have an email account with a provider, and an alias on that account setup on their server, the message should only indicate it was coming from the alias address. But some providers may have the server configured to include the sent-using header, in which case the from header and the sent-using header will be different. Maybe that is a flag for spam filters, I don’t know.

You should contact your email provider and discuss the issue with them. They may have a solution.