Email signature Drops Jpeg

I have set my email signature with a jpeg picture in it. I looks fine when I preview the email. When it send the jpeg turn into a small white box. I aslo show the small box in the sent email, and the receiving email. How do I send a jpeg inside the email signature

You could open the image in your image editing application and save as with a different file name (this is not the same as renaming the file in Explorer) or in a different format like png. Then edit the signature and replace the existing one with the new one.

I have same problem I have done your suggested solution but it didn’t work. Any other suggestions how can this be solved?  

You could check that you inserted the image or pasted the image, and not inserted the image as a link. Other than that, if you have a Pro License, you might want to open a support ticket.

  I did inserted picture even reduced size.  
Menu/Tools/Settings/Mai/Templates and Signatures/Signatures 
I have tried both options: 
 1) Signature settings / More / Insert Image
 2) Signature settings / Menu / Insert

Non off those work. Driving me mad. No other suggestions, have no Pro Licence.

You can send me your signature file and I will have a look. Close eM Client and copy C:\Users[username]\AppData\Roaming\eM Client\snippets.dat to another location. You may have to enable hidden folders in Explorer to do that. Send the copied file and the original image file to me at gary@gmx.se.

  Thanks Gary just did.

From Vy’s emails it was determined that the message was being composed in plain text, which does not include images.

Thanks Gary it took us a while but it’s done and sorted.
Thanks for you patience. 

I have the same problem. It saves the image pasted in signature to windows temp folder. So once temp folder is deleted. The image path has no image. Please developer change the signature image path to some other directory then temp. Not expected this from such a great software.