eM states that it is not the default mail handler within its general settings.

After clicking to make eM Client the system default, the program continues to represent that it is not. Typing a url from the windows run prompt does bring up eM Client and Internet options reports that it is the default client.

Can you please open the Control Panel and make sure eM Client is default mail application?

I have the same problem. Within eM Settings General - “Make default” button for Default Email Application does not do anything.


if problem still persist can you please try to update to this version? http://www.emclient.com/dist/v5.0.183…


We’re on version 7 now, and after 5 years this is still not solved! Has this thread been abandoned?
My Windows 8.1 computer is OK, but my Windows 10 is not. The application’s “Make Default” button does not work. Any further ideas please?

I think this was fixed a few versions back in 7.1.31849

In windows 10 you are directed to the default manager where you are suppose to be able to pick the program and set the defaults.  Not quite true.  Mapi Transfer is not set because there is no mapi variable available.  However there is a solution for now and that is to use the older default program now hidden in the bowels of windows 10.  Some programs take you to this module but the call is frowned on.  So… create a shortcut using this address… C:\Windows\System32\control.exe /name Microsoft.DefaultPrograms /page pageDefaultProgram  The mailto and mapi items are available after you set the emclient program as default.

Note: I tried mailbird and it grabbed the mapi transfer, so I had to set the default to outlook and then reinstall emclient.  I believe you may have to install outlook to use mapi.  This is the microsoft protocol that allows you to send documents, etc directly to the default email program from within an application rather than saving the item and then picking it up with the email client…   This is something that emclient fixed in version 6 and the problem reappeared after the last windows 10 major upgrade.  Mailto: and mapi are something that em should deal with perhaps by collaborating with Microsoft.

It’s still not fixed in the latest versions (Windows 10 and eM Client) in June 2021. Hopefully someone will read this bumped message and deal with it.

This is because your OS has defaults for some settings assigned to other applications.

In your Windows settings, please go to Apps > Default Apps, then scroll down and select Set defaults by app.

Find the eM Client entry and click on Manage.

Set all the options to eM Client.

Thanks for the tip - that worked just fine. I’ve never needed to go further than setting an email program as the default program before - the others have all presumably updated these settings without assistance. Thanks again,



1 Like

What are the steps in Windows 11 to make eM the default?

In Windows, go to Settings > Apps > Default Apps.

Click on Em Client.

Set all except the last two (webcal) to eM Client.

1 Like