eM does not accept password "server invalid credentials...."

I just installed eM client, and the program keeps asking for my password, and it does not accept with a comment “server says invalid credentials…” Please help, otherwise I will have to delete the program. Thank you

Hi Ernest, what mail service are you using to host your mailbox, are you using a Gmail or an Exchange account?

What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About?

Hello Paul! (1) I have been using Windows Live Mail in my Windows 7 computer. I want to migrate my e-mail to my new windows 8.1 using eM (the e-mail coming with win 8.1 is not good). In the meantime, until we can resolve the eM problem (server invalid credentials…) I am using the generic e-mail from my internet provider Time Warner Cable (TWC). You have my e-mail address.

(2) The eM version I just installed in my 8.1 computer is 6.021372.0

Please see if you can find a solution for the password problem. And if can, then where do I enter the info to activate my e-mail, i.e. incoming and outgoing servers.

Thank you for your courtesy

Hi Ernest, if the server prompts you with an invalid credentials error, I’m afraid you may not be using the correct password for successfully authenticating with your mail server, please make sure you’re using the correct credentials, your full email address and password that you can login to your webmail as well.

Use the automatic setup using the valid credentials and check if the issue persists, if it does, are you using any security software that may have disabled the application’s ability to connect to your mail server?

Cant find answer to my problem which keeps ocoring

All my password/settings are correct & wrote down & screen capeured. so NOT wrong.???

Hello Paul,
try logging in without the domain part of your user name next time the error occurs.
If tat does not help, please tell me what kind of account this happens on.


I had that issue with Gmail and I then recalled that I had to go into my security settings at Google and set up an app specific password just for eM Client.  Once I did that it would connect with no problems.  Just another day using 2 step authentication…

Read https://support.google.com/accounts/answer/185833?hl=en and search for " Create & use App Passwords".

This led me to https://myaccount.google.com/security

At which point, I did not try to set an app specific password, figuring that it would be complicated to do so.

Instead, I turned on “less secure app access”, which worked perfectly. I only use GMail for junk stuff and another account for private Stuff, so I do not care. You may want to add an App password just for the client, but I cannot tell you how.

If your Gmail account is setup as POP3, then yes, you need to enable less secure apps in your Google settings.

That can happen when the account is imported from another email application like Thunderbird. Therefore I suggested in your other question to remove the Gmail account from eM Client and add it again. That will set it up as IMAP and will work without app passwords or enabling less secure apps.

1 Like

Thanks. Good reply, and I am sure that it will help someone. However I have marked it as imap, not POP. In any case, I am just glad that it works now