eM Client won't launch / fails to open

I recently installed eM Client on my PC (running Windows 10 Home 64-bit, up-to-date and virus free). At first it was fine, I linked an email account from my ISP, then unlinked that and linked a couple of new gmail accounts and started sending and receiving mail. However, since then, when I turn the PC on it frequently won’t open. 

When I click on the icon a little pop-up appears, which says it’s checking a database and that it wasn’t shut down properly last time, then a couple of green ticks appear and the pop-up closes. And then nothing. Task manager shows it as running, always marked as 32-bit for some reason, I’ve tried closing it there and re-opening, that worked the first few times but no longer helps.

I’ve tried ‘run as administrator’; making it my default mail app; the repair and reset tools in Windows settings and I’m running out of ideas. Should I just uninstall and start again?

I’ve made some other changes to my PC in the last few days - I added a new non-admin user account, set up a Microsoft account etc, changed passwords, but nothing that should have messed it up.

One thing you might try is to uninstall eM Client, making sure not to delete the database directory when asked. That way all your data and settings will be there later.

Then go to the Release History and download the latest version of eM Client. Install that and see if there is any difference. eM Client also relies on .NET, so make sure the version in your OS is up-to-date.