eM Client with gmail - where is the Spam folder?


I’ve been using eM Client for the last week or so. It’s configured to work with my gmail account, which it does very well - email, calendar, chat, etc.

One niggle though. The “Spam” folder in gmail doesn’t seem to be available in eM Client. There’s a “Junk E-mail” folder, but this is always empty (whereas using gmail’s webmail page, it’s not). This is kind of important because sometimes the gmail spam filter doesn’t quite work & genuine emails go in there.

Have I done something wrong in configuring the account?


My gmail spam shows up in the Junk E-mail folder. It is possibly related to an option on the account settings, IMAP screen, at the bottom “Automatically detect special folder names”. I have that checked, and [Gmail]/Spam associated with Junk.

Thanks. I used all the default account settings. When I checked the various folder settings, I saw the following:
* the “automatically detect special folder names” option was checked (ie on)
* Sent: [Google Mail]/Sent Mail
* Drafts: [Google Mail]/Drafts
* Trash: [Google Mail]/Bin
* Junk: Junk E-mail

I’m wondering why the junk folder looks different to the others. But when I change it by hand to [Google Mail]/Spam, nothing changes.

Even more confusingly, when I right click on the “Junk email” folder to bring up the properties box, then select the “General Information” tab, the location is given as gmail/Junk E-mail (ie why gmail and not Google Mail?)

I must confess to being a bit ignorant in these matters, but perhaps this might shed some light on the situation for everyone else!


As a test, I fired up eM Client and manually dropped an email into the Junk E-mail folder. When I went back to my web browser and looked at gmail via webmail, the Spam folder was still empty but - lo and behold - a new folder called “Junk E-mail” has been created. Not what I had wanted to happen!

Mine is definitely different. Try setting it up like this. I think it will fix it.

Thanks. I did that yesterday, and all hell broke loose - strange new folders being created, etc. I deleted everything (the entire account) & went to bed. This morning I started again, and suddenly it’s all working perfectly…??? The IMAP tab now looks like this:

I’m not sure why it’s [Google Mail] instead of [Gmail] (except that when I created the account about 4 or 5 years ago, UK users’ email addresses were all googlemail.com instead of gmail.com for some reason. Anyway, it seems to be working :slight_smile:

Thanks for your help.


they might have your folders saved like this on their server, it will not affect function (this is actually how it should look).

Also sometimes eM Client does not receive all information when account is added by Automatic setup, because server (not only google) sometimes does not send all information that eM Client needs.