eM Client will not connect to gmail account - authentication fails

eM Client will not connect to my gmail account so will not sync contacts or calendar. This is the main reason I switched from Outlook to eM Client. It will not accept my identity credentials–authentication failed. I have checked and rechecked to make sure I have entered them correctly but have not been successful.

I have read the responses from a couple of other questions on this same topic. None of them have a solution. This is a critical issue and certainly will affect my decision to move to a paid version. Please advise.

Have you gone into your tools/accounts/calendar and contacts and enabled the service?

It’s in trying to enable it that the problem occurs. LIke I said, it is rejecting my user ID and/or password, both of which I am using correctly.

My son just solved the problem! The problem is Google’s 2-step Verification Process. eM Client cannot handle that process so it will not authenticate. If you turn off the 2-step Verification in your Google account, it authenticates without a hiccup.

Good to hear…nice to have a smart son!

This is a problem. 2-step Verification makes my Google account, but there is no way at this time to keep it on and still have eM Client work. I suggest the staff find a way to solve this challenge.


can I ask if eM Client shows any error messages when trying to connect over 2 step authentication?



you can use the 2steps verification with emclient.

Go on the Security page of your google account.
Below the 2steps options (bottom page), you have to generate a new password specific for the application.


I had the same problem. Pulled hair out trying to resolve. If you use Google 2-step verification, you need to remember to Generate a password that only emClient will use. After generating a new password, the program works like a champ! Thanks for the reminder Iogonxa.