eM Client v 9.0.1708 Printing

Is anyone else having problems printing messages after upgrading to v9 on Windows 10?

If I open a single message and select Print the Windows dialog opens and can print that message.

However, if I select one or more message displayed in the Inbox and right-click Print, nothing at all happens. Same if I select Print from the menu with one or more inbox items selected.

Any help would be greatly appreciated. Cheers

Looks like a bug. I just tried that and get the same issue - right click/Print does nothing.
Version 9.0.1708

mmm that is unusual Might be something with Windows 10. Do you have all the latest Win 10 patches and updates etc for the OS ?.

I cannot replicate that issue on Windows 11 with the same eM Client V9.1708.

The eM Client print dialogue box allways appears “when I right click” after selecting any amount of messages in the inbox.

Interesting. Yes, I have auto-update on, in Windows 10 and the very latest updates installed. John_A who responded above is having the same issue. Wonder if he’s on Windows 10?

The issue occurs on my Windows 11 computer and 3 x Windows 10 computers, all fully updated and no 3rd party security apps.

I’ve checked my Windows 10 (19044.1706) on emClient (9.0.1708 (2cfb4a5)) selecting one, two and more Mails on the inbox view - took some seconds to prepare the PreviewPDF, but worked like a charm.
So here, everything works fine.

I have tracked this bug down!
I always have Menu > View > Layout - Messages panel OFF

I changed the setting to “Messages on the right”, Right click > Print now works
Turn Messages panel OFF, Right click > Print still works
But when I restart emClient (with messages panel off) - Right click > Print doesn’t work again

Definitely a bug in em Client

Temporary workaround:
turn on either Menu > View > Layout - Messages on the right or messages on the bottom.

Note: If you already have Messages panel on right or bottom, turning Messages panel off will not introduce the bug until you restart em client

1 Like

Thank you John_A
Your discovered workaround is brilliant and works as a temporary fix on my machine as well.

Definitely a bug that should be addressed in upcoming patches.
Cheers, Geno

Thank you for the steps to reproduce this bug.

1 Like

Any updates? I find that am using the newest version and having same issue. Never had any problems with printing before this latest update.

I appreciate the work around though. Not the most convenient, but at least it’s something.

This has been fixed in 9.1, which will be released soon.