Em Client takes forever downloading outlook.com messages

I have been running EM Client for over a year with no problems on my outlook.com account. Lately it takes about 5-10 minutes from when a new email arrives until I can actually see the content. The status box on the lower left corner always says “synchronizing messages for…” and the icon on the account just spins and spins. I have deleted the account on EM and created a new one. I have also clicked “Repair” under the account settings. Did outlook.com change something that screws up EM Client? Anything else I can try? There are only about 200 emails in the account. 


I was having similar issues.  Someone suggested setting up a new “Exchange” account.  There is another thread on how to do this but I can’t find it.  Go to Menu> Tools>Accounts.  Click on the “+” in the lower left.  Do no use auto set up.  Click on “mail” in the lower left.   Then from the options choose “Exchange.”  After setting up the account you should see a tab that says “exchange web services” not Smtp or Imap.

Thanks, did it fix your problem when you configured as Exchange? 

Yes, it fixed my issues.  I did keep the old SMTP/Imap account until I was assured the new one worked ok.  After setting it up select the star tab to make that account your default. 

Thanks, that worked! I re-created the account selecting Exchange, and it automatically set up everything from there. Messages open up instantly now, thank you!

Hi…I am using Hotmail.  I tried to set up as Exchange account but I can’t do that.
Do you have any other suggestions…?  Thanx for any help…

Do you have any idea what changed with Hotmail…?

Supposedly MS made some changes and didn’t let anyone know.  You are probably just not filling in the required info properly.  There is one point in the Exchange setup where it asks for you name.  You have to put in your email addy, not your user name.

I didn’t have to do anything special when I selected Exchange, just email address and pw, no other setting. 

Thank You so much for the help.  I was able to set up ‘Exchange’ with your help.

Thank you again…I’m pretty happy now…!

I think this is a common issue and the developers should switch to Exchange settings when detecting an outlook.com or hotmail.com address, instead of the “auto” which cause problems.