eM Client Rules

Cannot get any eM Client rules to work! Have looked through help, and checked on line including videos. I have created rules as per eM Client help instructions, but still they do not work. All I need is a simple rule such as I want all email from ABC Games to be sent to my ABC folder which is located under my Local Folders. If anyone knows of the simple way to do this, I would greatly appreciate it.

I am having same problem. I can not get any rules to work. Please help.

If you could post a rule (screenshot), then someone could look at it maybe help.

I have rules like that in eM Client, created using the Rule Wizard.  They work perfectly for me (although the Wizard options are somewhat limiting). 

First, you open the Rule Wizard, and highlight the template: “Move messages from someone to a folder.”  Then in the rule preview box (same Wizard screen), you click on the “from people” highlighted link.  This opens another popup box (called "Searched addresses) where you can enter a “new address” – it’s asking for a full email address.  They don’t have to be actual “people”.

If the email address you want is located in your Contacts, you can press the Contacts… button, and it will pop up another box where you can select an address from your list of Contacts.  (You do that by clicking the appropriate checkbox.)  Then in that Contacts pop-up, you press OK.

When you have all the addresses entered properly that you want covered by your rule, you press OK in the “Searched addresses” pop-up.  That brings you back to the Rule Wizard pop-up. Down in the Rule Preview of that box, it should say something like this:  After message has been received from ‘xyz@abc.com’, ‘team@bcd.com’ move to folder.  Several of the words in this statement will be in a blue font, and are clickable, but you don’t need to do that now.

Rather, just press the Next button once (or maybe twice), and the pop-up screen will change to “Select actions for the rule”.  For this kind of rule, I check “move to folder” and usually also “stop processing other rules”.  Only have checked the ones you actually want to use.  You’ll need to then click on the blue word “folder” in the Rules preview.  This brings you to the Select Folder pop-up, which provides a list of all your folders.  Highlight the one folder you want to move mail to from your entered email address list.  Then Press OK in the Select Folder pop-up, returning you to the Select Actions box.

Then press the “Next” button at the bottom of the Select Actions.  This takes you to the Select Exceptions screen, where you can select items as needed.  When finished with exceptions, press the “Next” button at the bottom of the Select Exceptions screen.

You’re now at the Finish Rule Configuration screen.  The Wizard pre-populates a Rule Name, but you’ll want to change it to something meaningful to you.  Also, be sure that the Enable Rule checkbox is checked.  Finally, look once more at the Rule Preview (bottom of pop-up) to see that everything looks as you expect.  If so, press the “Next” button at the bottom of that screen.  You should now see your new rule with a checked box on the main Rules Wizard screen, and you can press the Close button.

Sorry for the length – it’s much easier to do than to explain in words.  Plus, with practice, you’ll discover various shortcuts.  But I thought it might be helpful to have it explained in detail. 

If emails don’t move properly after carefully entering your desired info/choices, you may have conflicts with other rules in your collection.  Then you may have to play with the order of your rules, check or uncheck “stop processing other rules”, or make some other changes to achieve your objective. 

Hope this helps.  In writing this, I created a new rule and wrote down the steps.  It works… :slight_smile: ~Mark

Doesnt work RULES for all mails… The letters are not playing with rules automaticaly, only in manual mode. WHY ??? Functional doesnt work.

Rules only apply to new messages as they arrive in your Inbox. So if the message was already read in eM Client, or read on your phone, or your server moved it to another folder, Rules will not apply to that message.

If that is not the case in your situation, can you give a screen-shot of the Rule? If it contains personal information, send it to me private message. Click on my name, then message.

So if u look at pictures, you will see that all time when new messeges are come in they all time sort in INBOX folder, not to each other with RULES. How i can repare it cus i cant buy product for my company without normal working all modules and rules.

When i can recieve an answer, Cus now i try to chose mail programm for my organization and if you do not answer i think that we buy another product…

Can you check that the email address in the Rule is the exact same address the sender has used to send you the message?

Добрый день, Hello, again same error in sorting of mails… Again mails from my colleague goes to INBOX folder and not in to HIS own folder… He send letter to me, but put in my address in COPY - with my another colleague. Why EMclient have so big troubles to form RULES and work with mistakes ???

Delete the existing Rule for that contact, then create a new one by right-click on his name in the email you received from him and choosing Create Rule From.

As long as the message from him arrives in your Inbox, and has not been read on another device or application, the Rule should work.

Well, it seems you are experienced with ‘Rules’. I also created a rule for my emclient, as an example 'message from adresses like @advertisement-easy delete directly and for ever. 99% of those messages are anyway in my junk folder and I have now the choice: 1. Select all in junk folder and delete or 2. call rules, select my rule, select which accounts (I’m using 4) and select which subfolders the rule should apply. So my questions to you: 1. is it possible, to start the rule before calling new message, so that they are deleted automatically or is it at least possible to activate just one button, so that the rule is applied with all my (otherwise always to select manual again and again) preferences for this rule?
Thanks for your answer

Unfortunately eM Client Rules do not apply automatically to folders other than the Inbox. So if the server has already moved the messages to spam/junk, eM Client won’t touch them.

So, if I want to get rid of the spam messages, I have to redirect them to INBOX?
Wow !!!

Yes, if you want a Rule to do that, they need to be in the Inbox as Rules only apply automatically to new messages arriving in the Inbox. The spam/Junk folder is not affected by Rules.

But most providers have a retention policy on the spam folder, so they should be automatically deleted after some time. If not, just right-click on the Junk folder in eM Client and choose Empty Junk folder.

We also have a new option in version 9 to do this for you automatically.

There is no problem with redirecting all mail to INBOX in Gmail.

The problem is I have tonnes of SPAM in Gmail INBOX on my phone while the laptop is switched off. I can’t keep my laptop with emClient switched on all the time to keep INBOX clean from SPAM. That stops me from redirecting all SPAM to INBOX.

The possible solution would be emClient for Android but there is no such version.

I have tried to export my rules to XML and import them directly to the Gmail box to enforce rules even when the emClient on the laptop is turned off, but Gmail doesn’t understand this XML file.

How to avoid such a problem?
Thanks.