eM Client rule not marking messages as read

I’m hoping someone can help me out with an issue I am experiencing with eM Client. I have created a rule to move messages to a specific folder and mark them as read based on a particular keyword in the subject line from a specific sender. However, the message is successfully moved to the designated folder, but it is not being marked as read.

I have tested this by removing the rule for moving the message, and in that case, the message is marked as read as expected. So it seems that there may be a problem with the way eM Client handles the combination of moving a message and marking it as read using the rule I have set up.

Has anyone else experienced this issue, and if so, have you found a solution? Any advice or suggestions would be greatly appreciated.

Can you display a screenshot of the rule?

Have you tried creating a second rule to mark as read in this specific case. I am sure you have already but worth a try if not.


If I run this rule manually, it works. And this rule used to work some time ago. It feels like this behavior started after some update.

Try adding to the bottom of the rule a line that states “and stop processing other rules”


I’m sorry, but that method did not work.

Thank you for your suggestion. Creating a second rule to mark as read could be a good workaround, but ideally, it would be better if the original rule could work as intended.

Just ran a test using this rule and it worked for me.


Ran the rule again after changing the “move to” folder to a different name, and it worked again.

Try deleting the rule and recreating it…

Ensure you are running a recent version…

Thank you for the tests.
I tried deleting the rule and creating a new one, and with my test email, the rule started working. But… the next day, I discovered even stranger behavior.
New messages were once again not marked as read… and yesterday’s message, which had already been marked as read by the rule, became unread.
I then realized the difference in eM Client’s state with a working rule and a non-working one - minimized in the system tray and not minimized. Further investigation showed that the rule doesn’t work when eM Client is minimized in the system tray.

oh! thank you for creating a post about this
i’ve added another check mark and everything started working as it should

This is a known bug, and our developers are working to provide a fix.

1 Like

Thank you for your reply!