eM Client prints a mail only as image, so exported PDFs are not searchable

Hello eM Client-Team!

I use eM Client 7.0.26653.

When I print a eMail with a PDF printer driver or use the printer driver of OneNote (“Send to OneNote”), the mail is always exported as an image. That means, I cannot search for text in the PDFs I exported. I’m using the PDF printer driver since some years and did not change anything. This driver works with other apps like Word, too. Same with “Send to OneNote”.
Every email I tested had this issue.
If I remember correctly, eM Client 6 had not this issue.



I tested another PDF printer, Bullzip Free PDF printer, which did work with Firefox, Edge, IE, but not with eM Client. (The first one was PDF-XChange printer.)

And I have to correct myself: “Send to OneNote” seems to always export images into OneNote. So that’s normal.

Maybe it’s a Chrome issue, since em changed its rendering image to Chrome from IE in release 7. Try printing a web page from the chrome browser.

Yes, printing with the PDF printer via Webmail is a workaround. Thanks, Jay!

Tested I with Microsofts “Print to PDF” - same. Maybe it has something to do with the switch from IE to Chrome as a rendering engine of eMclient.

I found a workaround:

There is a free, open source tool (Apache license) with a Windows GUI:  EML to PDF Converter
It’s on Github: https://github.com/nickrussler/eml-to-pdf-converter

You don’t have to complile sources, install Java or use the command line. There is a Windows installer(Setup.exe): https://github.com/nickrussler/eml-to-pdf-converter/releases

The converter has a batch feature, can extract attachments from EML files, save them to a seperate folder and - most important - adds the metadata (date, address… )to the head of the PDF.

Extremly useful!

Is there any update on this matter? I have the same problem; whenever I print an email to pdf printer, the outcome is an image and thus not searchable nor selectable. I have 7.0.22822.0

Yes, Version 7.1 has solved this issue.  I printed to a .pdf and I was able to search text in the document.  Also, I printed to OneNote with the same result.

Version 7.1.30794.0 has not solved the problem. My PDF’s are not searchable. Please let me know your method of printing. - Thanks

If you print with this method, you will have a searchable pdf. I am sure it is the same method that Jay used.

Menu > File > Print (or Ctrl + P) > Save as PDF