eM Client fails to connect to the SMTP server

After configuring emclient [the latest version] receiving email works fine but I am unable to
send any email. I use Universal Telecom and copied the SMTP address (smtp.uvtcmail.se) and port (587) over from Thunderbird where it was working perfectly [Outlook work fine as well]. I went to the diagnostics tab and it indicates server not responding. I have even tested port 465 with all the different types of policy settings. There were different error messages in the log depending on the port used in the SMTP settings. Port 587 - Error Message: An attempt was made to access a socket in a way that is prohibited by the access permissions. Port 465 - Error Message: The connection attempt failed because the connected computer did not respond within a certain time or because of the established connection to the host computer no longer works. I have tried the automatic config and the account import but that did not work either.

When  I use the fix button in emclient on the diagnostics tab it indicates fixing failed. Given that I have no trouble with SMTP using Thunderbird or Outlook [full client] it appears there is a software problem within emclient. There seems to be thousands of people with similar problems. Do you have a solution?

Best Regards
Robert Örnskog

Hello Robert, are you using any security software on your computer, such as a firewall or an antivirus with enabled protection on these ports? Please try to temporarily disable these security elements and check if the issue persists. If it does, can you please make a screenshot of the error and submit it to us here on the forum or copy the content of the log from the log tab and submit it to us both?

What version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About?

Thousands of people with the same problem? I’m not quite sure if I understand what/who you’re referring to, can you please specify this?

Thank you,

Hello Paul
* I have disabeled my security software but it do not help.
* I’m running version 6.0.22344.0
What do i mean with thousands of people? If you search on your forum on SMTP connection error you get thousands of hits.

Log Message
21:21:46 robert.ornskog@uvtcmail.se [SMTP]  Connecting: To robert.ornskog@uvtcmail.se
21:21:46 robert.ornskog@uvtcmail.se [SMTP]  MailExceptions.SocketException: Connection failed due to the following reason:
21:21:46     “Ett försök gjordes att få åtkomst till en socket på ett sätt som är förbjudet av åtkomstbehörigheterna 85.93.192.195:587”
21:21:46    at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
21:21:46    at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
21:21:46    at MailClient.Commands.Command.Process(WorkerStatus status)
21:21:46 robert.ornskog@uvtcmail.se [POP3]  Connecting: To robert.ornskog@uvtcmail.se
21:21:46 robert.ornskog@uvtcmail.se [POP3]  Connected: To robert.ornskog@uvtcmail.se
21:21:46 robert.ornskog@uvtcmail.se [POP3]  Downloading messages: From robert.ornskog@uvtcmail.se
21:21:46 robert.ornskog@uvtcmail.se [POP3]  Disconnected: From robert.ornskog@uvtcmail.se
21:21:46 robert.ornskog@uvtcmail.se [POP3]  Disconnected: Done


Hello Robert, can’t unfortunately find anyone experiencing this issue at this point, please note this is a very general error and can be suggesting multiple issue - based on what’s included in the log. As I can see you’re using an incorrect account setup, you don’t have your SMTP service setup properly, based on the Port you’re using. Please adjust the security policy on your account to “Force usage of SSL/TLS” and check if the issue persists.

The logged error is suggesting you’re unable to access the server due to use of incorrect port settings or that the port was accessed in a prohibited way. Port 587 is a secure port and thus can not be used without security layer.

Regards,

Hello Paul
I have configured the SMTP settings with your suggestion, but it did not help. See the attached pictures.

Why do port 587 work without secure connection with Firefox and Outlook?

Best Regards
Robert Örnskog



Are you using any security software on your computer or in your network, such as Proxy or firewall? Please try to temporarily disable any security software on your computer and check if the issue persists. The error in your Log tab suggests the connection is being blocked by an external element as it is denied for the application to access the mail server.

Regards,

Hi Paul
It was not the connection settings on the SMTP tab that needed to be changed. After I disabled anti-virus and anti-spyware for the third time it still didn’t work. There was nothing in the logs either. I reinstalled all the security software and then I could see in the log “access protection” that there was port blocking on the eM Client. I excluded the exe file for eM Client, and then it worked.

Thanks Paul for leading me on the right track [external blocking]. I love the look and feel of eM Client and I will use it from now on.

Best Regards
Robert Örnskog

Hello again Robert, glad you’ve found a solution for this issue, please make sure to let us know if you come across any other issues or questions about the application we’ll be happy to help.

Regards,