eM Client doesn't work with the CalDAV Server of the Synology DSM 5.0

Using the same settings with DSM 4.3 eM Client worked with the CalDAV like a charm. We have now upgraded to DSM 5.0 and eM Client isn’t able to connect to the CalDAV at all. Removing the account and recreating it changes the account to CalDAV/CardDAV, but not a single calendar is found.

The log says:
00:33:06 fortec [CalDAV / CardDAV] MailExceptions.ConnectionException: Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden… —> System.Net.WebException: Die zugrunde liegende Verbindung wurde geschlossen: Unerwarteter Fehler beim Senden… —> System.IO.IOException: Unerwartetes Dateiende oder 0 Bytes vom Transportstream erhalten.
00:33:06 bei System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
00:33:06 bei System.Net.PooledStream.EndWrite(IAsyncResult asyncResult)
00:33:06 bei System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
00:33:06 — Ende der internen Ausnahmestapelüberwachung —
00:33:06 bei System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
00:33:06 bei System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult)
00:33:06 bei MailClient.CalDav.ProtocolCommands.RequestCommand.Execute(HttpWebRequest httpRequest, CancellationToken cancellationToken, Action`1 logBody)
00:33:06 bei MailClient.CalDav.ProtocolCommands.Connector.RunCommand(CalDavAccount account, ICommand command, CancellationToken cancellationToken)
00:33:06 — Ende der internen Ausnahmestapelüberwachung —
00:33:06 bei MailClient.CalDav.ProtocolCommands.Connector.RunCommand(CalDavAccount account, ICommand command, CancellationToken cancellationToken)
00:33:06 bei MailClient.CalDav.Synchronizer.BootstrapCommand.UpdateOptions(Uri[] baseUris)
00:33:06 bei MailClient.CalDav.Synchronizer.BootstrapCommand.Execute(WorkerStatus status)
00:33:06 bei MailClient.Commands.Command.Process(WorkerStatus status)

Hi, what version of eM client are you using? Are you receiving any error messages from the application?

Thank you,

I’m using 6.0.20154.0.
Please find the error dialog attached.

Hi again, how did you setup the account did you use the CalDav setup from the new account window?
What’s the behavior of the account now, can you sync anything or does this error popup everytime you try to do so?

Thank you,

First I used the existing account (and yes, I have set it up with the assistant), but then  I deleted the account, and recreated it with the assistant. It ends up with a CalDAV/CardDAV Account without ANY calender within the account. Therefore it does not work at all.
If I use another installation and stick to the formerly working account, this error keeps popping up.
So I think, retrieving the calendar details fails with DSM 5.0 on synology.

Hi, the question was if you used the assistant for CalDav only accounts under the Calendar tab instead of the manual setup, sorry if this wasn’t clear enough.

Thank you,

I have used the CalDAV assistant by creating a new account under calendar/caldav. I have used the same assistant to create the old account working under DSM 4.3. I did not know, that there is a manual way to do it.

Sorry that’s the correct way to set it up, I meant the automatic setup not manual as I by mistake have written.
Can you please go to Tools > Settings > Advanced and turn on CalDav logging for the account? Save the settings and restart the application, when the error shows up again go back to the advanced settings window and click on send logs, add my email to copy ([email protected]), and add a reference link to this forum topic.

Thank you,

Logs sent to you.

Any findings???

Just for your information: Our company was about to buy lincenses for all workers, but this will be done when the program is working with the synology caldav server. So please give us some feedback, if this will work again soon!

Hi, I’m sorry for the belated reply.
I’ve checked the received logs and unfortunately found out they’re empty.
Can you please try making sure the issue is properly logged, turn on the logging save the settings, restart the application and when the error message occurs, send the logs?

Thank you,

I have repeated the logging. But unfortunately, this is everything I can find in the logs after the error message:
13:08:09.473|014|   C: OptionsCommand https://reha11syn.is.tuwien.ac.at:5006/Kalender/

Every error message brings up one log file with the same content. Maybe it it easier you try it yourself on a synology server? Or I can try to use wireshark for more information? What can I do to help you?

If you do not have a synology, you may use a virtual one. Use this information http://www.wijngaard.org/virtual-synology-with-dsm-4-3/ with the latest build http://xpenology.com/forum/viewtopic.php?f=14&t=2219

Hi, one more thing, could you please download fiddler (http://www.telerik.com/fiddler), install and run the tool.
After you do so, go to Tools > Fiddler Options > HTTPS, and check the decrypt HTTPS option.

Run eM Client and when you receive the issue again, go to File > Save > All Sessions, and save the logs as the .saz archive and send it to my email ([email protected]).

I hope we can find more information in these logs.
Thank you,

Hi, as you mentioned in the email it really doesn’t contain much information, can you tell me what URL address are you using for the CalDav account and if it works when you open the URL in your browser (it should show a login window, waiting for credentials).

Thank you,

If I open the very same path (https://reha11syn.is.tuwien.ac.at:5006/Kalender) using a webdav tool, I can see the listening of the calendar directories. If btw Fiddler is running, the webdav tool does not connect.

And if I use Sunbird on the same computer it works, too. The only difference: with sunbird I have to connect to every single calendar. So the url contains the calendarname in addition.

Can you please make a screenshot of your current settings from the Tools > Accounts window and post it here?

Thank you,

What antivirus software are you using and are you by any chance using any firewall or proxy settings on your computer?
You mentioned you want to use this in your company, have you tried the setup on another computer?

Thank you,

I am using this from three different computers. Two at home (so a NAT translation takes place) one at work. At work, the server and the computer is on the same segment without any firewall inbetween.

My colleagues are using eM Client too and they have the same problem. So it does not depend on a specific computer nor on a specific user account. 
The server was upgraded to the latest openssl version (due to the known security bug). The webdav connecton on the very same server (and same port) does work with Windows 7 and Totalcommander. So there is no problem for other tools to get connected.

The CalDAV server is used by Sunbird, Lightning the android Sync Tool, iPads and a Plugin for Outlook without any problem.

If you like, you can try to reach the given server yourself. I could - if necessary - give you a calendar account for testing purposes.