eM Client doesn't seem to work well with G-Data in my environment

Hey All,

I’m currently switching to eM Client. I’m coming from Thunderbird. Basically, the eM Client works great, except for one thing: it doesn’t seem to work well with G-Data. The mails are retrieved very, very slowly and a timeout is thrown regularly.

12:17:19 [MyMailbox] [IMAP] MailClient.Accounts.ConnectionException: Synchronizing folder ‘[MyMailbox] Manu/Inbox’ failed due to the following error: Server did not respond in 00:01:00
—> System.TimeoutException: Server did not respond in 00:01:00

In G-Data I use the option “Check SSL connection”, and of course I have also stored the certificates in the eM Client (as well as Thunderbird). In Thunderbird everything seems to work. I can download all mails in Thunderbird without any problems. If I deactivate this option (“Check SSL connection”), everything works also in the eM Client, except that the mails are no longer checked by G-Data.

Does anyone have any idea what is going wrong, what I have configured incorrectly.


Because the server is taking so long to respond it timeouts. It could be a server issue, or something is interfering with the connection.

As a test, can you completely disable any anti-virus, firewall, proxy or VPN, then try again. Sometimes even restarting your router may resolve this.

Without G-Data, everything runs fine.
Thunderbird doesn’t have this problem with G-Data.
I don’t think there is a server-, VPN-, firewall or any other connectivity problem.

What’s G-Data ? Can u elaborate on that.

This is a part of the marketing description of G-Data:
End-to-end cyber defense: G DATA developed the world’s first antivirus software in 1987. Today, we defend our customers against all kinds of cybercrime with end-to-end solutions and services …

I had already been in contact with G-Data support. They don’t know any problems, especially since it works with Thunderbird without any problems.

Without G-Data, everything runs fine

I have also stored the certificates in the eM Client (as well as Thunderbird).

As G-Data is then an Antivirus type program and eM Client works ok with it disabled as you say, then it could be similiar to some other Antivirus programs like eg: AVG and Avast, where even if you “export and import the certificate into eM Client” and also “allow eM Client permission into your Antivirus program” , the Antivirus programs still sometimes block eM Client receiving mail.

It could be the certificate in G-Data may not be eg: 100% compatibility with all mail clients which could explain why it works with Thunderbird & not eM Client. Dunno. Suggest if you have an eg: G-Data forum on your Antivirus website, see if anyone else has struck this problem before and found a fix.

Most eM Client users (who have similar issues) just end up either “disabling the email scanning part of the Antivirus program” so it’s still running resident real-time but not interfering with the emails receiving, or use an alternative Antivirus program that will work ok with scanning enabled.

I personally for Windows 10 & 11 just use the Windows security built in which includes Antivirus and Malware checking real-time and doesn’t interfere with eM Client receiving mail.

Hello everyone,
I have the same problem. GData support also suggested that I switch off the virus check for SSL/TLS. Then I was informed that eM Client is not one of the officially supported mail clients. Since Thunderbird always ran reliably with GData for me, I think that eM Client does something different here than other programs. I therefore hope that the developers of eM Client will improve this again.

But I have one more question. How can I import the GData certificate into eM Client? I just can’t find the spot.
Best regards


Apart from “Allowing eM Client access within G-Data” the below is how you import a certificate.

How can I import the GData certificate into eM Client? I just can’t find the spot.

To import an exported Antivirus Certificate into eM Client V9 go to “Menu / Settings / Signing and Encryption / Certificates and Keys”

Then click “Manage Certificates / Keypairs” at the bottom left.

Next click on “Import” at the top and then select your exported antivirus certificate as in the below example AVG MailShield.der antivirus certificate below.

Finally, once imported click the “Other Certificates / Keys” at at the top, and you should see your G-Data certificate appear. Lastly click “Save & Close” and exit eM Client Settings.


Hi cyberzork,

thank you for the explanation to import a certificate, but this does not solve the issue. I have imported the certificate (from my first post):

[…] of course I have also stored the certificates in the eM Client (as well as Thunderbird).[…]

The eM Client works well with many other antivirus programs. I think G-Data has to solve the issue.



The eM Client works well with many other antivirus programs. I think G-Data has to solve the issue.

Yes eM Client does work ok with many other Antivirus programs, and agree G-Data developers need to find a way to make it work with eM Client.

Hello cyberzork,

Thank you for your description. I was able to import the certificate cleanly. I just assumed that only certificates with which you directly encrypt and decrypt the e-mails belong here. It was not clear that transport encryption was also meant here.

What did you mean by this statement?

@All: After importing the certificate and restarting eM Client, I was immediately able to cleanly sync all my messages to my web.de mailbox. I was even able to re-enable virus check for SSL/TLS. In most cases this seems to work. In addition to my web.de account, I also have one with gmx. Basically I don’t use it. However, spam mails have been arriving there at very short intervals for weeks. The resulting volume of messages with all the harmful content then still lead to a connection error in the eM Client. I keep watching.
Greetings Andreas


What did you mean by this statement?

Some Antivirus or combo Antivirus / Security programs have an area where you allow the mail client access as an “Allowed program” so its not blocked.

eg: AVG and AVAST & others have an area called “Blocked and Allowed app” where you have to add eM Client as an allowed program. So if G-Data has an area similar to that, then add eM Client. You can check with your G-Data support if it has such an area. If it doesn’t then nothing to do there.

Hi cyberzork,

many thanks for the quick response. I don’t have the function you describe. This is called GData Application Control and is only available in a bundle with other functions. I only have the virus scanner running here. So nothing to do. Thanks again.

Greetings Andreas