Em Client Calendar Notifications - making me crazy!

I have been trying em Client and really liking most of what I have seen. I am pretty much ready to subscribe except for ONE problem and I am hoping someone can help me figure it out.

When I use Outlook and first open it, after say a weekend, all of my missed calendar notifications pop up ion a single outlook notification window. From there I can choose “Dismiss All” (and they all go away and dont come back) or I can dismiss/snooze them one at a time in the window.

For em Client, the notifications pop up one by one in the Windows notification center and in the corner of my tray with a pop up window. If I have missed say 20 of them, I either need to wait and not to anything as they pop up one at a time and I X them out, or I can open the notification tray and choose Clear All. However then they keep coming back so I have batches of old events continually popping up and disrupting my work.

Is there any way to alter the notifications settings to deal with this? Is there an emClient notifications only vs Windows notifications, that will let me batch Dismiss old items?

Any help or advice to deal with this would be hugely helpful thanks!

1 Like

I get this issue all the time too ( we have an exchange server)

Hi Lirong
I had a similar issue in terms of that notifications that I pressed on dismiss kept coming back. It was not always the case, so I had problems to reproduce the problem to @Gary, who is the top guy in support from emClient.

Its in the same ballpark, so you can tell Gary hello from me and discuss a mitigation solution. He should recognize the issue.

I found an option in the settings to disable system notifications. This seems to have addressed my problem.

I’m looking for a setting like that. Could someone tell me where it is? I’ve looked everywhere.


You can disable all Past Notifications in your Calendar if you don’t want to manually dismiss past events by doing the below. See @Gary post below from the following thread.

(Gary’s Post extract from above thread)

"Go to the Calendar section of eM Client and switch to the Agenda view. You will see the icon on the toolbar after Day - Week - Month.

Uncheck “Hide Past” option by clicking on that icon. You should be able to see all your past events.

Select all events for which you want to dismiss notifications.

Open context menu by right clicking any of selected events and chose Reminder > No Reminder

You will no longer get reminders from past events"

This was perfect, very helpful. Did not see this on my own. Thanks!