eM Client 9 Sync Issues

Recently upgraded to eM Client 9 and now I have went back to eM Client 8. Emails are not synchronizing properly in version 9. When reading an email in eM Client, it will not mark the message as read on the server. No issues when using version 8. This causes a problem when trying to sync across multiple devices. We’re loving eM Client and recently became a reseller. Hope this issue gets resolved in an update. I should say, the issue does not give an error and does not create logs. Weird, I know, and makes it harder to narrow down to fix.

1 Like

What type of mail server are you using ? Can we get more info / details on this ?

Also are you using Windows or Mac eM Client and what exact V9 are you running ?

Is it a eg: Microsoft company type or EWS Exchange 365 server or normal POP, IMAP, iCloud ISP mail server or your own custom mail server you connect to in a local office etc ?

Ps eM Client V8 connections are the same in V9 except alot more features in V9 which also now supports alot more newer authentication stuff with mail servers as well for PC and Mac.

Read flag sync issue in EWS accounts has been resolved in last internal version. Wait for next release.

1 Like

Thank you for the replies. We are using SmarterMail with eM Client Version 9.0.1361 (647eeb3). I understand that version V8 & V9 connections are the same, however, I am still experiencing sync issues in V9 that I don’t experience with V8. When I delete an email from V8 or V9 they are deleted from my webmail. When I read an email in V8, it is marked as read on webmail. When I read an email in V9, it is not marked as read on webmail. eM Client uses EWS to connect to our email server which is our own server in office running Windows Server 2019.

Vladimir, any idea when the next release will be?

Again, thank you both for your replies.

You can try internal build 9.1549 mentioned in this thread 3 days ago. I have no issues with it.

1 Like

That fixed it! Thank you so much!

How does one do this?
I also seem to be facing challenges with Active sync. i am usign webtop mail client, based on Nethserver

EDIT: Seen the Link.

Sorry, I don’t understand your question.


I also seem to be facing challenges with Active sync. i am usign webtop mail client, based on Nethserver

If you are having issues configuring your specific mail server with the webtop browser based gui front end to ultimately then use eM Client mailer, suggest to contact your server support as this forum is only for eM Client support / setup.

However if you are only trying to connect or configure eM Client for use with your mail server, can you let us know what type of server it is eg: EWS (Exchange) , Linux or other different type, and what version of the specific mail server you have, and have you done all the mail server updates etc.

Also do you have eM Client for Windows or Mac and what version ?, and what Windows or Mac OS version you have.

Lastly if you have eM Client for Windows have you tried the latest official V9.1361 release version or the above updated interium (not officially released build V9.1549) as @Vladimir_Losinsky advised. Or if you have Mac OS have you tried the latest V9.1360 (Beta 3) build. Need more information.

You can get all the eM Client official & interium updates via the version history page anytime.


I found this topic while troubleshooting mail read/unread flags not being sync for a customer using emClient (EWS) with our server running SmarterMail.

After updating emClient to build 9.1549 part of the issue is resolved.

When a mail read state is changed from emClient, it is reflected server side (it wasn’t with current released build)

However when the read state is changed server side, the change is not automatically reflected, at least visually on emClient.
It needs a manual action such as refreshing the folder or browsing another folder and going back to the folder so it triggers a refresh.

Any other of you affected with the original issue seeing the same behavior with the internal release?

Thanks a lot for your replies.