e-mail with attachment sent but stuck in outbox and keeps resending

I create an e-mail and add an attachment.  When I send the e-mail, it appears to have not sent as I get an error and the e-mail stays in the outbox.  But the e-mail has been sent and this is not recognised and it gets resent and still stays in outbox.

Hi Julie, what version of eM Client are you currently using on your computer, can you check for the exact version number in Help > About? What mail service are you using with eM Client?
Can you please make a screenshot of the error you’re seeing?

Thank you,

Hi Paul

Sorry for taking so long to get back to you, I have been out of range.

I am on version 6.0.21040.0

I use TPG mail service.

I just sent a message with attachment to screen shot the error, and it works now!  Amazing!

So I guess we leave this here for the moment.  But it’s great to know you are available to help.


Ok.  Thought it was too good to be true, the error is back this morning.

I can send e-mails without attachments with no problems.  And I have received e-mails with attachments with no problems.

Hope you can help as I am applying for jobs and it looks very unprofessional when I have e-mail issues.

Hi Paul

Further to the detail above, I have worked out a temporary fix:

  1. Request delivery receipt
  2. Copy myself in to confirm send
  3. Watch sending process and check my e-mail to confirm send
  4. Move e-mail from outbox to sent items

Of course, I’d like to avoid these additional steps.

I still need help with this please.

Hi Julie,

Maybe it helps if you install the latest version of eM Client:


Thanks Hans.  I have installed the latest version now so will see how that goes.

Still cannot send e-mail with attachments without problems.  Ahh!  A fix please?


Do you have more than 1 e-mail account? If yes, do all those e-mail accounts have this issue (sent e-mails with attachments stay in the ‘outbox’)?

Maybe you will need to change the ‘port’ and ‘security policy’ on your SMTP tab for this e-mail account?

Maybe you will need to send logging to eM Client.

Thanks Hans.  I only have one account.  What would I change the port and security policy to?  Current settings attached.  How do I send logging to eM Client, are you from eM Client?


Hi Julie, when the error occurs, can you please switch to the “Log” tab, copy the content of the log and post it here on the forum?
You can also try to use the “Server required authentication” option as most servers requires this, but please check with your mail service provider for the recommended server settings.

Thank you,

Thanks Paul.  I just sent to e-mails to get the Log and wa-la they worked!  I am on my laptop so I’ll test tomorrow from my computer, and compare the two, and come back to you.

two e-mails that should be

I am suffering with this same problem,

the error : 8:29:30 AM     “Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”

But the mail is sending multiple times,  I am spamming my clients.

Please help