E-mail accounts not shown

I have 6 accounts listed in account settings and two of them (gmail and yahoo.ca) are missing in the main interface. How to fix this? Tried to assign missing accounts as default, no success

Are IMAP (or POP) and SMTP selected in the “services” section of the account settings? If not, the accounts are not shown in the main interface.


Yes, they are selected. Also diagnostic tab does not have the test button in those two accounts.

Just tried to unselect, save and reselect POP and SMTP, no effect

If you are using a Free License they will not show in the main interface as you are restricted to the number of accounts you can use.

If you are using a Pro License, you can take advantage of your VIP Support option and open a support ticket with eM Client. They will be able to assist you further.

Hi Gary, thank you for the response

I was going to purchase a Pro because I need more than two E-mail accounts but right now I am testing the trial option so no VIP support available.

It seems i am facing some glitches importing accounts from Outlook as they imported as IMAP (I choose to stay as POP) and when I removed them and created new ones they become not shown in the main interface although shown in the account settings.

Maybe it is related to license restrictions but this makes me uncomfortable purchasing the Pro license until I see that it works for me smoothly

My advice is never to import the accounts. Rather create the accounts yourself in eM Client, then just import the data from MS Outlook. That way you setup the accounts as you wish, and if using Automatic Setup, other benefits like associated calendars, contacts and oAuth from the provider may be available.

This could be because of a few different reasons.

  1. You have a Free License activated. So, as I said they will not be displayed.

  2. The accounts have not yet connected to the server for the first time. Only once the accounts have connected and begun the first download/sync, will the folders appear in the main interface. You could look in Menu > Operations for any errors related to those accounts in the Log tab. There may be some hint there.

  3. When setting up a POP3 account, you have chosen to use Local Folders. In this instance, all the messages will be in Local Folders and not a separate account tree for each account.

Thank you very much, yes, probably it was option for local folders, I re- created the account using “create separate folder” and it is now OK.

I somehow removed a line for Unread messages and also the mailboxes which have new mail are not highlighted. Spent almost an hour learning settings and could not find how to restore these items. Could you advise please?

Overall although I am only getting familiar with this mail agent, I have a feeling that it satisfies my needs and I will purchase a Pro license, just need to do some more housekeeping and make myself comfortable with it

Thanks again!

Right-click on Favorites and choose Display > Unread.

eM Client does not highlight folders with new mail.

Thanks again, Gary,

Unfortunately in my experiments I also removed checkbox for Favorites in that menu so now I can not do right click on them :slight_smile:

I am pretty much sure that in the beginning I saw orange half moon marks on the left from the account names and I thought those are for marking unread mail which might be something else. That is not an issue if I can restore Favorites and Unread item in it

What I like in EM client is that it works with my yahoo.ca and gmail accounts which old Outlook 2007 can not handle anymore

Best regards,

Go to Menu > Settings > General and tick Show Favorite folders.

The unread markers appear on the messages, not the folders.


The folder themselves only show an unread count.


Thank you Gary! It seems after your efforts I may finalize switching to this app from the Outlook. This will allow me to have everything in one place like in the old good times :slight_smile:

You gave me a good start. I now see my questions were dummies’ questions, thank you for your patience :slight_smile:


1 Like