Draft editing not possible?

I’m having a strange problem with editing a draft (created in Outlook.com (OWA)).

I can edit the draft using the Outlook.com (OWA), but not using emClient.

When I create a new draft in emClient, I Can edit it in emClient, And Edit it in Outlook.com.

Further, the Drafts folder in emC would not update until I Repaired it.  It seems to be displaying the draft as if it were a email message, Not with the composition form.

Clue: *** The (uneditable) Message Properties dialog displays a Sent Date.  (?)***
  *** So, why is an Unsent message displaying a Sent Date ? ***

Should not emClient allow editing of any item in the Draft folder, if its fully compatible?

This is a necessary important feature.

(Win 7 Pro, SP1, emClient Ver. 7.0.27943.0)

I believe you can only edit a draft that was created in emc.  A workaround is to right-click on the draft and click on forward/forward as original.  The to: and cc’s will be lost, but all the email information remains intact.

Hello Edward,
do you have this Hotmail account set up as IMAP or Exchange in eM Client?
Either way, we will need logs to see where the problem is.

Make sure you have the latest eM Client installed - http://www.emclient.com/dist/v7.0.27943/setup.msi
Go to Menu>Tools>Settings>Advanced.
Enable IMAP/EWS logs for your account.
Restart eM Client.
Right-click the Drafts folder, Properties>Repair, click the Repair button.
When the resynchronization finishes go back to Advanced setting, click Send logs buch change the recipient to rust@emclient.com
Add the link to this forum thread in the body so I can get back to you about the issue here on the forum.

Regards,
Olivia

Olivia,

Under Accounts, there is no indication that the account is setup as IMAP or Exchange, except that the server is:
https://outlook.office365.com/EWS/Exchange.asmx

I have the latest emClient installed. 7.0.27943.0

The logging options listed are:
    Logging
      acct@hotmail.com
      -OfflineAddress book
      -Exchange Web Services

I have seen the “Enable IMAP/EWS logs” previously, somewhere…

Jay,
Under EAS 16 the Drafts edit problem is remedied.

Jay,
Under EAS 16 the Drafts edit problem is remedied.

Good to know. Thanks for the update

Hello everyone,
I got a reply informing me that this is currently a known issue we had with Microsoft Exchange servers and fix will be provided in eM Client 7.1.
Thank you for understanding and your patience.

Regards,
Olivia

Terrific! Wonderful!!

Thanks Olivia!!!

HI.  A relatively new user, this issue continues to be a problem.  I need to save a draft (directly composed on EmC) and then to be able to edit it later for sending.  AS I often send to 8 or 10 or more people (I am a teacher) itis a PAIN to have to reset the “to” or “cc” items.  ANY Success resolving this?   I use EmC directly, and gmailis the provider. 

FURTHER bugs - cannot set correctly, defualts for column headers.  Cannot seem to open AT THE SAME TIME? Mail and contacts (or calebdar)) ANY workarounds? 

Thanks guys!
Regards, David

Hi,
No matter what mail client is used for creating a draft, if draft hasn’t been edited only  by emc, it is not editable by emc, except using a turn-around.
This bug exist for many years! 
When  will it be fixed?
Regards,
Pascal

I do not experience this problem with 7.1.32088. In fact I regularly edit drafts in eM Client that I began elsewhere. This is usually with regular IMAP accounts, but I also tested it with Exchange accounts.

Pascal, is this a particular server, or does it happen with any email provider?

Hi,
Thx for reply.

I did these experiments:
change email provider —> same result

  • Firstly write the draft with Thunderbird —> Draft is editable with emc
  • Firstly write the draft with AquaMail (android app) ----> Draft is not editable with emc BUT  is editable with Thunderbird.
  • Firstly write the draft with gmail (android app) ----> Draft is not editable with emc BUT  is editable with Thunderbird.

So it seems emc cannot edit draft  created or modified with an android client application. 

Regards.

Thanks for the additional information. I did not try the Android option, only desktop applications and web interface.

I guess this is something for the developers to look at. As Olivia has already commented in this thread, maybe she will take it further.

Is there a way to transmit this information to the support ?

If you have a Pro License, you can open a support ticket. Otherwise, this forum is monitored, so it should be picked up.

ok thanks

Same problem in Win 7/32 with Gmail drafts from iOS. PITA.

Problem is still there, even drafts created in eM Client itself cannot be edited!! I’m a new user (7.2.34016.0) and this will soon become a show stopper for me! (A pity because so far emc is the best windows mail client I’ve tried. (although still not as good as AquaMail but this is only for Android…)

It’s crazy that this bug isn’t fixed yet, but I’ve found a workaround. It appears to be a problem if you have conversations enabled, but if you go into settings -> mail -> disable conversations then the draft will show up in the draft folder as an individual mail and you can double click it to edit. The bug is with conversations so if you double click you get the separate conversation window which doesn’t allow editing. They should fix the bug so that double clicking in drafts doesn’t open conversation views, it just edits the current draft.