Downloading items from Server failed on Move to Folder iPad

Using the latest eM Client for iPad V10.0.2080 with iOS 17.4.1, I had been trying to move an email from a IMAP account Inbox to a IMAP account label on the iPad for half the day.

When i selected a Gmail label to move it to, the “Moving to folder” little square appeared in the middle and just stuck there.

After a very along time i eventually got the below error “Downloading items from server failed” as per the screenshot below. So it was though eM Client mob app couldn’t access my mail account.

So i disabled and re-enabled my data mobile connection and also tried my wifi connection and same problem. Rebooting my iPad made no difference. Every time i pressed move to folder it stuck on moving.

Now i could access my mail account folders from the iPad ok via Microsoft’s webpage, and i could access my Gmail mail account folders from the iPad ok via

So had to be a problem with the eM Client app somewhere. I tried repairing both the account and the Gmail account in eM Client app and made no difference, so I eventually removed the account and as soon as i did that, eM Client mob app “crashed straight back to the IPad home screen”.

So appears the account had become corrupted in someway within the iOS mobile app causing the move to folder problem.

After adding the account back into the iOS mobile app, i could then move that message from my account Inbox to my Gmail account label no problem at all within a sec.