Deleting Email in Inbox does not work

I have upgraded my eM Client from Version 6 to 7.

After the update I see several deleted eMails again.
But the problem is, that I cannot delete Mails from the inbox. The Icon Delete does not have any effect. Deleting works in other folders.

What is the problem?

Addition: I ́ve just recognized, that I can delete new Mails. Only these “Zombie-Mails” I cannot delete.

same problem here

I have the same problem.

Running an hMailServer and accessing it via IMAP with EM7.

Deleted Mails (marked deleted at hMailServer) are still shown at EM7, but can’t be moved or deleted again. Also it is not able to show the mail content. Only sender and subject are visible.

I am running EM6 on another machine and there I can’t see them and everything is fine. Same on iPhone, iPad and Outlook 2013 and 2016.

Same problem!

Is there no resolution?? :frowning:

Also waiting for a quick resolution. With this bug em7 can’t be used at all, because it messes up the inbox. Waiting for a quick update or a least a feedback about fixing time. At the moment, the only option is to delete em7 and go back to em6.

I have the same problem. Is it possible to find out where the non-deletable messages are stored? I know my messages are stored in OS(C:).Users/[UserName]/AppData/Roaming/eM Client. But I can’t figure out where the InBox is stored in the eM Client folder. If I could find the InBox storage location II could easily delete the contents. Perhaps eM Client Inc. will see these messages and help us.

I think it should not be our task to find a “way around the problem”. It is the task of emclient team to fix that problem. And because the problem does not exist in em6, it should not be so difficult to fix it in em7.
Moreover I would not mess around in the App Folder, because as far as I know, also some database is involved in em7. So just deleting emails might not delete the database entries.

Latest version is 7.0.26887.0 which corrects this problemo.

I am using 7.0.26887.0 and still have the same problem.

me too

I am running 7.0.26887.0 right now and the problem still exists. Please fix!

Not sure if there has been a resolution to this or not. But I too am seeing this issue with the latest release of 7.0.26887.0. Has support contacted anyone regarding this?

Im running Version 7.0.27920.0, but still have this problem with "Zomie-Mails".They have no content, but cant be deleted.

we are aware of this issue and found that changing the Conversation view usually removed the ‘zombie mails’ for some users ( Menu>View>Conversations ).

As for better solution, if you want to help us in resolving it we’d appreate if you could send us your database files for inspection.
The location of your DB files is found in Menu>Tools>Settings>General>Storage.
Zip the database and send it to
Add the link to this forum thread to the body of the message so we can get back to you about the issue faster.


I noticed already, that the problem is “solved”, when the display of the conversation is deactivated.
Zip the database? The entire folder? This is over 200 MB…

Hello Marcus,
some users have database files in hundred of GB.

Either way, I’d suggest using a Cloud service like DropBox and such for sending the file to us, if your database is too large and you wish to help us in inspecting this issue.


Simple to delete the account and start it over again, then everything went back to normal especially the stuck email is gone! But…you have to make sure that your email account is IMAP!

Dead and simple! :slight_smile:

I’m seeing this since upgrading to 8 - is there a solution other than the one proposed here ? When I change conversation views, the deleted email disappears as discussed above.