Delete autocomplete

Good day! When i start to address the recipient of an email, I get numerous suggestions to autocomplete the email address. How might I CLEAN all the names out, so that the autocomplete starts new?

thank you in advance.

This should work: MENU > Settings > Mail > Compose > Email Address Suggestions

Ty, I unchecked the box. now to see what happens on the next email.