Default Tasks folder is not working in the Agenda view

If you open a new task within the “Tasks” section then the default folder, which is being set under the account setting, is being chosen.
If you open a new task under the section “Agenda” then the default folder is not being chosen. Instead of that the local folder is being chosen (see screenshot).

Is this a bug or what is the reason why this is being handled in a different way? In my opinion this should be handled the same way as the the “Tasks” section.

Hi Maurus, sorry to see this, however I’m not completely sure what you’re referring to, what Agenda view do you have in mind? 
What version of eM Client are you currently using on your computer, can you please check the exact version number in Help > About? What synchronization service are you using with eM Client?

Task should always be assigned to the default folder for the account in which you’re focused on at the moment. In case you’re creating the task while focused on an account without a task folder, the default task folder should be selected.

Thank you,
Paul

Thanks.

eM Client Version: 6.0.21372.0.

Agenda view, see screenshot. I hope this helps further.

If you choose to create a new task out of here then you get the following screenshot (no matter if you have defined a default tasks folder within the accounts section).

All other options, for example going over the Menu: File -> New -> Task or over the icon below is working. It also works if you’re in the Taks section (see screenshot).

Here it’s taking the default folder which is being defined in the accounts section.

Hi again Maurus, unfortunately I was still unable to replicate the issue, even if I create a new task using your instructions default tasks folder is always selected in the new task settings.

Can you please send me an email to mcgregor@emclient.com with a reference link to this forum topic.

Thank you,
Paul

Thanks.

Made you an e-mail and today we had both a look on it. Now the problem should be clear.

Hi Maurus, as I’ve mentioned before, thank you for reporting the issue, we’ll be working on a fix for upcoming releases of the application.

Sorry for the inconvenience,
Paul

Thanks.