Default email not working

I have about 10 email addresses in EMClient.  To help my not send from the wrong one, I have setup a dummy address called noemail@noemail.com as default.  This forces me to choose the correct outgoing email address.

After upgrade to the EM8 Beta, that address is not coming up on new emails.  Another address it.  

Yes, I am in the All Inboxes when creating the email.   I double checked my settings and noemail is set as default.  

Any help would be appreciated.

Barb

For issues with beta versions, please send your questions to testing@emclient.com

Yep, was just hoping someone here would already know.

You could go to Menu > Accounts, and make sure that account is set as default, but if you have, and it is not working, then you should contact testing@emclient.com

Remember that beta versions may not have all functions enabled, are are meant for testing purposes only.

Yes, I had checked that.  I have even tried setting another email address as default, but I am still getting another one when I go to send an email.

Apparently this resolved itself after a restart.  I noticed this morning the correct email is coming as the default.

Hi Barbara,

Did your resolution “stick” and continue working?

After I change my default email address in the Accounts setting to one of my aliases, the very first time I compose a new email, the “From” field (just to the right of the «Send» button) is prefilled with the chosen alias — which is the behavior I want. But the next time I compose a new email, the “From” field reverts back to the original account email address, not the alias.

In v7, I’m able to change the default email address to one of my aliases, and it “sticks” to that alias every time I compose a new message. Unfortunately, in Beta 8, it no longer works this way.

Hi Gary,

I sent an email to testing@emclient.com last week describing this problem in detail, but I never received an acknowledgment reply.

I’m currently using 8.0.1796 on Win10.

Thanks!

Andy, you may be using the word alias incorrectly as it already has a context in eM Client, where it is a second address assigned to an existing email account. Maybe you are referring to just another email account as an alias cannot be assigned as the default send address?

The send address also depends on which email account folders you are in. Say you have two email accounts setup in eM Client; one Gmail and one Yahoo!. If you are in the Yahoo! folders when you compose a new message, it will choose the Yahoo! address to send from. If you are in the Gmail folders when you compose a new message, it will choose the Gmail address to send from. The default address is only used in situation like when you are in Local Folders, or in another section of eM Client.

Who knows why the eM Client team are not responding. Guess you will just need to wait and see if there is a reply.

As Gary said it needs to be a different email account.  That’s why I created a fake one.  If I forget to change the outgoing account then it sits in my outbox.

Yes, after I rebooted my computer it now works.

Barb

Thanks to both of you for your quick responses.

Gary,

I do mean a_lias_. I use a number of aliases in my primary Gmail account. These aliases are under my own domain names (and they also function as secondary logins to that same Gmail account).

In other words, I have userid@domain1.com and userid@domain2.com as aliases to userid@gmail.com.

In my userid@gmail.com account, I have userid@domain1.com set up as my default «Send Mail As» address. Therefore, from the Gmail web interface, when I compose a new message, the From field is prefilled with userid@domain1.com.

In eM Client 7, I have the same configuration. I have the alias userid@domain1.com as my default Send address. This is functionality that has existed in eM Client for many years, ever since I started using it a couple versions back.

You can try it yourself:

In eM Client 7, Go to Menu:Tools:Accounts and select one of your Gmail accounts. Under «User Information», change the Email field to any of your aliases for that Gmail account. Hit «OK» to save the change.

From now on, any new emails you compose in eM Client 7 from your Gmail account will default to your chosen alias as the sending address.

Unfortunately, in eM Client 8, if you go through the same procedure, only the first message you compose will default to the chosen alias. Subsequent messages (and the Accounts setting you previously changed) will revert back to your regular Gmail address.

For those of us who use aliases in Gmail (vs G Suite), the way eM Client 8 currently handles aliases is a potential dealbreaker.

Barbara,

Sorry for hijacking your thread. I misunderstood what you were trying to accomplish with your default sending address. My concern is slightly different than yours.

Thanks!

Aliases CANNOT be set as default addresses, but you can change the send as address to anything you want. That is NOT an alias.

I will use eM’s terminology in BOLD:

In my case, I have userid@gmail.com set up as my DEFAULT ACCOUNT (starred) in «Menu:Tools:Accounts». For that default account, I have the Email field filled out with userid@domain1.com, which is an ALIAS of that account (both within the Gmail web interface and within eM Client’s list of aliases under «Menu:Tools:Accounts:Aliases…»).

And to be absolutely clear, I typed “userid@domain1.com” into the Email field manually, not by selecting from the list of aliases that I had already added to «Menu:Tools:Accounts:Aliases…». Is this your only concern?

When I compose a NEW MESSAGE in eM Client 7 — whether the focus is on that Gmail account or any of the SMART or LOCAL FOLDERS — the email automatically defaults to userid@domain1.com as the Send As address, without me having to manually choose it from the dropdown in the NEW MESSAGE window.

In other words, the alias userid@domain1.com is my prefilled Send As address when I click the «+New» button (or use its associated SHORTCUT) while any of the SMART, LOCAL, or userid@gmail.com folders are in focus.

userid@domain1.com is not an ACCOUNT in the list of accounts in «Menu:Tools:Accounts».

So yes, from my point of view, I have an alias set up as my default sending address.

As you said, “The default address is only used in situation like when you are in Local Folders, or in another section of eM Client.” The alias userid@domain1.com is the default sending address in these exact circumstances.

I have several other ACCOUNTS set up in eM Client, including an Outlook account and one other Gmail account. If the focus is on a folder for one of these accounts when I click the «+New» button, then obviously, the Send As address is not prefilled with userid@domain1.com, It’s instead prefilled with the address that is displayed in the Email field for the in-focus account in «Menu:Tools:Accounts».

" I typed this alias into the Email field manually"

This is NOT an alias. This is the send from address.

Yup, that’s the “Send From” address. I’m glad you and I are on the same page now, Gary.

eM Client Beta 8.0.2016.0, released yesterday, allows me to set my default “Send From” address to an ALIAS.

From the release notes:

8.0.2016.0
Monday, May 18, 2020
eM Client 8 Beta
[…]

  • Allow to use alias when setting up a Gmail account and don’t update it to the primary email address automatically

Yes, that is a GMail alias, not an eM Client alias. These are two different things.