Default actions for attachments

In Settings > Mail > Attachments there is a section for default actions for attachments.

.

There is currently nothing defined in here. There are no buttons to define any actions, nor does right-clicking anywhere in the window provide any options to do anything.

How do I define default actions for attachments?

Hi Tom,
you set these rules upon interacting with the attachment. When you open or download the file, the pop up window will ask you if you want to remember the decision and never ask again - and that’s when the attachment extension will be saved to this section.

Best regards,
Olivia

Hi Olivia,

Thanks for your reply. I’m not sure I understand what you mean.

If I hover over an attachment with the mouse I get the option to Open or Save.

If I right click in the attachments area I get more options:

But whatever I select I don’t get an option to remember the choice?

Hi Tom,
you need to double-click the attachment and then this window will pop up:

Checking this box will save the default action for next time in the Settings.

Best regards,
Olivia

Olivia
When I double click an attachment, I do not get the window you indicate.  I get an explorer window that opens and asks me the name I want to save the document to.  I do not want to save the document until I have read it.  I just want it to open.

Hi Patrick,
and do you not have the setting already accidentally set to downloading the document first? Check the attachment settings, please.
In any case, you can always manually open the file first if you right click the attachment.

Best regards,
Olivia

Thanks very much Olivia!

Like Tom above, “there are no actions defined” appears in the attachment settings, and no way to add any. I would like to define the action so it opens an attachment, not download and save. 

Hi Patrick, could you please take a screenshot of the explorer window you get when double-clicking the attachment?

I have the same problem. Whatever I do I receive an error message that says I am dividing by zero.
There is no entry in the attachments box but in windows there are defaults associated with most file types and certainly for .pdf
I am using Win 10. Is this the problem

john

Hi John,
could you please provide a screenshot of the error message?

Best regards,
Olivia

The problem is a bit different, but continues. I changed the tools - settings - mail - attachments, to state that pdf’s should be opened as a default.  There is really no screenshot to give you. When I try to open a pdf link embedded in an email via left click (or touch screen), it asks me where I want to save it by opening an explorer window.  When I right click on the pdf link the pop-up asks me “Copy link address, Copy, Select All, Find, View Mail Header, View Mail Source, or Zoom”.  I wish I could just open the darn thing.

Hi Patrick,
a link inside the email and attachment are unfortunately the same thing. The attachment setting can only apply to the files actually sent inside the email. I’m afraid if the pdf is sent to you in a link you will have to open that link in your internet browser.

Regards,
Olivia

So you’re telling me what? My issue is that I am not given a choice to open. Only to save. So does emclient not allow me to simply open a document link?

Hi Patrick,
I think you misunderstood - eM Client does open the link for you.
If your browser (instead of viewing the pdf inside the browser) downloads it, then that is your browser’s setting.
eM Client can only set up rules for the things sent INSIDE that email. If the pdf was send as an attachment, you could open it from eM Client. If it’s sent as a download link, then your internet browser is dealing with it.

Best regards,
Olivia

Hi Olivia, your answer here seems to be the closest thing I can find in this forum to the issue I am having.  I have had NO problems at all with EM Client until I did something I shouldn’t have done apparently.  I receive emails at my job all day with pdf documents, WORD documents and jpeg photos attached.  I have to copy the attachments and paste them somewhere on my computer to do the next step of my job.  When I click on an email that has attachments, the attachments were right there the second I clicked on the email and I could immediately copy them to do the next step.  But I had noticed the JPEG photos that were attached would also be open in the actual body of the email I received, so I was trying to just find a way to get the jpegs not to open in the body of the email.  So I went to settings where I found “default actions for attachments” and there were 2 actions listed there…1 action was for .pdf and the other action was for .doc.  Without even thinking, I clicked the “x” next to each action and deleted both of them.  Well now that I have done that, when I click on an email to open it, I have to sit here and wait and wait and wait and wait for the attachments to show up like they did before I deleted these actions.  So I came to the forum and found several people had said to go to IMAP and change the “offline” setting to download messages and attachments for offline use thinking that would maybe fix my problem.  Well now it is taking even longer for me to see attachments in emails and even longer for an email I just sent to someone to show up in the sent folder!  

In one of your replies above, you posted a screenshot of “Opening Mail Attachment” and to be sure and click the box that says “don’t ask me again for attachments with the same extension”, which I think is what I need to do to go back the way it was before.  But should I click “Open” or “Save” for the mail attachment?   I don’t want a bunch of attachments to start opening up and I don’t want the attachments to try to save somewhere else either.  I just want them to be sitting there looking at me like they used to be!  I need to be sure I click the correct option since it won’t ask me again!

I just want to go back and pretend I never deleted the attachment actions!  Can you PLEASE help me go back to it was before I ever deleted the attachment actions??!!!