Date on email is in US format

Hi!

I have a question regarding how dates are displayed. In my Inbox list, the date of an email is, for example:

14.01.02, 17:04

Which is how it should be. However, when I look in the top-right corner of the email itself, I see this:

1/14/2022 5:04 PM

Which not only has the month/day twisted about, but is also not showing in 24-hour format. Where can I amend this, so that the date display is consistent?

Many thanks!

You will need to check how the date is listed in the message header to see why it is not displayed correctly in the message preview. To do that, right-click in the message body and choose View Mail Header. Look for the Date: header line.

Copy and paste it here.

Here’s the date line from the header:

Date: Fri, 14 Jan 2022 16:04:58 +0100

Just to follow-up, I’ve checked through lots of emails and they are all displaying this way, with the date in the US format.

Can you check your Windows OS settings. See if the Regional format for short date is in the correct format.

If not, change it then restart eM Client.

I’m on a Mac, and it all looks correct to me.

Hey Gary - any more ideas or suggestions on this?

Hi there,

Any update on this?
I have exactly same issue with eM Client on Mac