Cursor/pointer disappears

Although working with the newest version 8 on a surface pro X the cursor disappears suddenly. I do not find out when and why (maybe when switching between touch input and cursor). It is quite uncomfortable.

is there a solution to this yet?
I run v.7 on Win 10 and always had my cursor disappearing with EM, but no other application.
been trying to fix for a few years but haven’t fund a solution. EM support won’t help either

Can you update to the latest version of eM Client listed in the Release History and see if there is any difference?

1 Like

it’s v. 7.2.40748.0
but I don’t think it has anything to do with updates since it’s been the same for ~ 2 years and I’ve updated several times

Much has changed in eM Client over that time, including changing the way the screen is rendered. A big change was made in the version just prior to what you have, so you should have that already.

One thing you can try is to download the release you are using again from the Release History. Then uninstall eM Client, and install it again from the new file. Uninstall/reinstall can often fix visual errors.

Thanks for the info Gary, but what do I need to do to keep all my mail accounts and data when I delete the program?

During the uninstall you will be asked if you want to delete the database directory. As long as you DON’T delete it, all your settings and data will be there after the reinstall.

As of 1Aug2021, this is still a problem. I haven’t been able to find any correlation between “whatever previous action” and the disappearance of the cursor. I am using EM ver 8.2.1473. The “disappearance” happens both with Windows 10 and Windows 11 (beta). The only thing I have found to bring back the cursor is to restart EM. It is irritating and annoying.

Can you try the latest version of eM Client available in the Release History and see if there is any difference.

OK, I just loaded the 1509 em service update. I’m running Windows 11 Insider Preview 10.0.22000.100 (co_release).

I haven’t been able to identify what specific task or action triggers the “disappearing cursor” behavior, so it might be a while before I can say one way or another that the 1509 update worked. I will try various things to trigger it, but no guarantees.

I rolled back to Windows 10 and will keep it as long as I can. Windows 11 is just strange. So, I have emc ver. 8.2.1509 and I’m still getting the disappearing cursor. Its getting very frustrating. I have to exit emc and then restart to get it back. When I search for this problem, it appears to have been around since at least 2016.

I’ve personally not seen this issue with eM Client on the Surface Book 2. Sounds specific to the Surface Pro. I wonder if the Surface Pro touch / mouse drivers need updating by Microsoft and are buggy ?

I would suggest to contact Microsoft tech Support either via their surface community website or phone if you are a paid customer.

Googling around there is many peeps who have Surface Pro’s and the mouse cursor/pointer disappears even when working in eg: Chrome browser.

It does the same for me if I use the touch pad on my laptop. I connected a Logitec mouse and disabled the touchpad and the problem does not happen. I have a Lenova laptop so it is not a Surface issue.

I am running a Dell Inspiron convertible laptop with Win 10 and latest em client. I can now consistently make the cursor disappear and then reappear, if anyone in development happens to be interested. If so, contact me. Thanks

Sure @vdub, we would be interested to know what you have learned.

You can contact me directly on

I should add what I later discovered. When the cursor disappears, I can roll it back down over the e-mail and it will come back. If I keep the cursor outside the e-mail box, then it stays invisible. I’m using the format with the em folders on the left of the screen, a short list of em’s in the inbox on the top, and then the open em below that.

I am experiencing this same exact issue running version 8.2.1721 on Windows 11, Dell XPS13 laptop. I thought I was the only one. It’s very frustrating as it seems that there is no solution other than to switch to another email client.

My only work around is to close the application and start it again. The disappearing cursor issue is only happening with emClient and no other application.

Here we are at 2023 with version 9.2.1735 and there is still no cursor in the compose window. Further, is it my settings or does the compose window push text right to the edge of the window? Literally the there is padding=0 along the borders of the compose window which is terrible for readability. Solutions?

Edit: The disappearing cursor and the terrible formatting in the compose window has to do with the Signature. emc doesn’t isolate the css well… so applying the default signature, changes the entire formatting of the compose window.