Crashing on dismissing reminders

My wife and I have a shared domain name and use a provider for Exchange services. I recently added my wife’s calendars to eM Client. Today, I had reminders for two of her appointments and when I tried to dismiss them, either individually or Dismiss All, eM Client crashed. I have not had a crash on this action in the past, either for my Exchange calendars or my wife’s Google calendars.

What version of eM Client are you running.

Also do you have Windows or Mac & what OS version.

eM Client 10.0.3117 (493de5a)
Windows 11 Home 22H2

eM Client 10.0.3117 (493de5a)
Windows 11 Home 22H2

Ok try closing eM Client and download and install the latest release version 10.0.3125 from the release history page.

https://www.emclient.com/release-history

If still the same problem, try uninstalling eM Client and “don’t delete the database” when asked on the uninstall wizard and then reinstall.

Lastly if still the same issue, could possibly be an OS issue and might need patching. Win 11 build 23H2 was released a while ago. Check your Windows update and install that if available.

Are you able to reproduce it? So does dismissing another reminder also crash eM Client?

Update:

I had to wait until I was getting reminders again after fixing the well-known “internal server error” caused by the way eM Client handles some attachments.

If I get a single reminder and click Dismiss All or select it and click Dismiss, the dialogue closes but re-appears with the reminder still there.

If I get a single reminder and close the dialogue, it goes away and doesn’t reappear until…

… If I get more than one reminder and click Dismiss All, eM Client crashes. When I re-open it, several calendars have become deselected. Not sure yet if these are the same each time.

… If I get more than one reminder and dismiss just one - I just had one reminder on my calendar and one on my wife’s. I dismissed mine and eM Client crashed. This has not happened if all the reminders are for me.

If it’s still happening with the latest eM Client, I would then suggest to test if it’s a possible corruption in the local database somewhere.

To do that, close eM Client and rename the hidden database to eg: eM Client-Old and then reopen eM Client and setup as new.

(Windows hidden eM Client database folder)
“Users\yourusername\AppData\Roaming\eM Client”

(Mac Hidden hidden eM Client database folder)
“Users\yourusername\Library\Application Support\eM Client”