Copy-pasted images are resizing even when set to 100% scale

Since the recent update to 8.1.979, whenever I paste an image into the body of an email, it downsizes very slightly even though I have the size set to “Original.”

Eg, I just now pasted an image 98 x 220 into the body of an email, and it immediately downsized to 84 x 198 even though it says it’s still set to the original 100% scale. It’s not. The difference in quality is noticeable. I can’t even set it “back” to 100% scale because it’s already set to 100% scale and upsizing it only makes it worse.

It didn’t exhibit this behavior before the recent update. When I pasted an image into an email, it remained exactly 100% original scale unless I manually resized it within the email. In my business, I often take a screenshot, crop out the bit I want, and paste it into an email to explain to the client about a website update etc, and what I paste should be exactly the same as what I just screen-grabbed, not a slightly downsized and poorer quality version.

Can you help? This is not a settings issue as far I’m aware. I have images set to 100% original scale.

I’m unable to reproduce what you’re describing. I use the same version as you.
I made several tests, even with very large photographs (up to 6000 x 4000). They were never cropped. I’ve tried both inserting them from the menu and copy and paste them. The results are the same. When images were automatically scaled I was able to return them to their original size.
Are you sure:

  • Defaut size = Original
  • ‘Automatically resize large images’ is not selected
    in Menu >> Mail >> Compose >> Images.

Hmm. Yes, the default size is original. Even if I rescale it with the handles, I should be able to right-click on the image and select “Original” and it will set back to its full size. But full size now is this slightly reduced version.

The “automatically resize large images” is not selected, and never has been, but I think that’s only for sending. I’m not even getting as far as sending.

Another quick test, one of many: I take an image that’s 300 x 200 and paste into the email. I right-click the pasted image in the email, and it’s got a check mark next to Original, as it should. But it’s still resized down a little bit. I click custom anyway, and it says it’s set to 256 x 51 (which is true, it is).

It has nothing to with dpi either, which I thought I’d check.

Strange, indeed. Maybe if you upgrade to the latest version (v8.1.1032.0), the problem will be solved.

Okay, updated to 8.1.1032.0, and no difference. :frowning:

How did you determine the size of the image after pasting it into the message you are composing?

Is it possible you have zoomed out slightly in the compose window, so the image looks smaller? Use Ctrl 0 to reset the zoom, and see if it looks any better.

As I said above, you can see the size by clicking on “custom.” And I can copy paste the image straight back into my graphics program and it’ll tell me the same.

I do graphics all the time and trust me, it’s not right. I did think about the view size of the email program itself, but no, it’s not that. This only changed when the program updated.

I appreciate all your answers! No dice yet though.

Unfortunately I am not able to reproduce it either.

If you have a Pro License purchased within the past year, you could open a support ticket with eM Client.

I am also not able to reproduce that issue with eM Client V 8.1.979 Windows.

Pasted images at Original Size are identical after pasting into messages.

eg: Here is one of my old Bike images which is 1200x1200 pixels before i pasted it from my computer.

When i first paste it in eM Client new message window (inline), i then click the pasted image once and then, click “Image Options” at the top left and click “Original” as per below example.

Then click “Image Options” at the top left and this time click “Custom” and you will see the identical pixel size of 1200x1200. Exactly the same as the original before pasting.

Thanks cyberzork. And yes, that’s how I determine the size of the image after pasting into the email (among other methods).

I did some more tests and noticed something. If I right-click > copy an image directly from a browser, then the image pastes into the email just fine, at the correct size. Same thing when using Windows’ built-in photo viewer (like when opening an image from Windows Explorer); I just right-click > copy image, and that works fine.

BUT, if I copy-paste the image into Paint Shop Pro or Photoshop first (which is generally what I’ll do because I need to do some work on it), then copy-paste it from there to my email, THEN it reduces down. This might be something you can possibly reproduce. I personally use Paint Shop Pro.

The main thing to note is that I never had this issue until I updated emClient a week ago. Something about emClient is different in the way it imports an image from a graphics program.

An example image from Google: 1000 x 667

Copy-pasted directly from the browser into emClient, it stays at 1000 x 667
Copy-pasted into Photoshop and from there to emClient, it reduces to 892 x 596
Copy-pasted into Paint Shop Pro and from there to emClient, it reduces to 850 x 568

Changing the dpi (but keeping the pixel dimenions the same) makes no difference, so it’s not that.

I use Corel PSP (2020 V.22.0.112 x64) so I did some testing. However I still don’t know if it is an eMC limitation ot not if images dimensions are reduced when copied-pasted from an app such as PSP.

For the record one cannot copy and paste ‘normally’ (Ctrl+C (or Ctrl+Ins) - Ctrl+V) from PSP to eMC. The option ‘Paste special’ and then ‘Copy for Screen or email’ should be used instead. The results always lead to reduced images in eMC. And there’s no way one could restore the original image dimensions in eMC.

For example, a 6000 x 4000 image from PSP is reduced in eMC:

  • to 1348 x 898 if one uses '‘Copy for Screen or email’
  • to 955 x 636 if one uses either ‘Copy for Professional printing’ or ‘Copy for Desktop printing’ (the option ‘Large’ in eMC is greyed for some reason in the case of desktop printing’).

More testing is needed however. I’m not sure yet the reasons to explain this behavior and if it’s eMC’s or Corel PSP’s fault.

Hmm, no, I use PSP 9, and in the Edit menu I only have a standard “copy” option, or CTRL+C (same thing). So when you say you can’t copy-paste “normally”… well, I have been for years! And the same simple copy-paste function works across the board for any image grabbed from browser, Word, photo viewers, etc – just wherever I can copy it to the clipboard. Only PSP and Photoshop are giving me this issue now, whereas they weren’t before.

I can’t help thinking it’s a meta issue or something like that. Maybe graphics programs have more information, and emClient now recognizes that… whereas that information isn’t available when grabbing from a browser… I don’t know, I’m just spitballing.

As I said, I never had this issue until I updated emClient. :-/

@wdesign Sounds like the bitmap pixel size (is changing somehow or not showing correctly) when copying from Paint Shop Pro or Photoshop to eM Client (which is unusual) as per images (do paste ok as you say) if you copy them via the Browser or the Windows built-in photo viewer.

My Motorbike Image example above was copied and pasted into eM Client from directly into eM Client new message window. I use the menu "edit select all, and then edit copy or ctrl-c.

See original Image below showing 1200x1200 pixels at 96dpi 24bit before i pasted it into eM Client.

@wdesign A possibility why copying from any paint program to an email message might not be the exact same pixel resolution is eg: If you say (manually dragged out / selected) the image area with your mouse, rather than using the select all / copy option you might not then get the exact pixel size in the Windows clipboard so then could be different when pasted into eM Client message.

Just a thought incase you may be manually selecting images & that might be the cause of the problem.