Copy & Paste Introducing an unwanted underline

I write long emails and often pre-write them in a document.  recently I find that although there is no underline on the word document there is one when I paste it over & I can’t delete it.  The Underline stays greyed out.  Any thoughts?

Hello Suzie,
have you tried the ‘Remove format’ option from the toolbar?