Copy of new email goes into drafts

Hey Everyone

Need help on this please.

So when i create a new email it creates a identical copy of the email and puts it in drafts but it isnt the complete email i sent only half of it.

Does anyone know what is going on please?

While you are composing an email, a draft is saved every 3 minutes. However, it should be automatically deleted from drafts after you send. If it is not being deleted, then it is possible that there are partial drafts.

What version of eM Client are you using?


Thank you for your response i figured it out, was a option in the settings.

Appreciate the help.

What option did you change, my draft folder always has many versions of the same e-mail even after it was sent.

There is an option in Menu > Tools > Settings > Mail > Compose. By default it is 3 minutes. I understand that there is also an issue with GMail and many drafts. Maybe a GMail user can comment on that.

Thanks! I had set mine to 1 minute, now back to 3.

As far as Gmail goes, there have been past versions where drafts were not cleaned up and they would remain in the drafts folder until manually deleted (although the final message was correctly sent).  I have not seen this issue in some time, but I still occasionally see it discussed on the forum.

The other issue with Gmail and drafts is that with some mobile clients (e.g., the gmail client for Android), drafts created on the mobile client cannot be edited in eM Client.  The workaround is to select “Forward as original” and they can then be edited.  You will, however, need to reenter the recipients.

Don’t use Googles e-mail (although I use many other google services). But I do have two other IMAP clients (IPAD & Android) manipulating my Netaddress IMAP e-mail servers.I will see what happens with above setting changed to 3 instead of 1, I expect it to at least cut down on the number of sent e-mails left in the draft folder.

Even if it creates multiple drafts, they should be deleted when the message is sent.  If this is not happening, that is a problem.

I performed an experiment…
I started a new e-mail, I left it open and added to it every 3-15 minutes for a total of 4 edits over 50 minutes. their was nothing in my draft folder until I saved the email one time (I typically have a habit of using “CTRL-S” many times when working on any document), after saving one draft appeared in the draft folder, then I sent the mail and the draft disappeared from the draft folder as it should. This is after I changed my “Tools > Settings > Mail > Compose” to 3 minutes.
Seems to be operating as expected now, was the problem ME or ???

I forgot, In Gmail it used to create multiple drafts instead of overwriting the last one, but I believed this has been fixed.

So, good, things are operating as they should for you.  It can’t be you, because like me, I’m sure you never make mistakes!