Continously getting "(507) insufficient storage" error

After sending an email of 10MB+ size, I’m now continously getting an error.

MailExceptions.OperationException: Sending email failed due to the following error: Remote server returned an : (507) Insufficient Storage. —> System.Net.WebException:
Remote server returned an error: (507) Insufficient Storage.

I guessed the email would be in my Outbox, so I could just delete it, and prevent if from triggering further errors.

Any suggestions on how to remedy the situation? Thanks in advance. 

Hi Thomas,
is your account set up as IMAP/AirSync/Exchange? If it’s any of these and not a POP account I’d suggest trying to right click on the Outbox folder or the whole account in the left side menu and choose Properties > Repair and click the repair button. This should resynchronize the folder/account.
If this does not help let me know.


Thanks a bunch! That sorted it :slight_smile: I found 5 unsent emails going back a bit.

Any way of preventing this from happening again? I’m sending via our Exchange 2007 and haven’t seen the problem with other email clients, so I’m thinking the problem isn’t server-side.

Just updated to latest version this morning, if that’s any help. 

Hi Thomas,
the problem is usually that the Exchange account have the max size of attachments for sending/receiving to 10MB, so that could keep the messages stuck in outbox (though it is strange that they disappeared from the outbox all together) - but that does need to be changed on the server.
If the emails did not have attachments or smaller ones, maybe there was a problem with the connection at the time you were sending these or you closed eM Client too soon previously before the sending was finished?
The only tips I have for preventing is checking your attachment size limit on the server and making sure the email is sent before closing the application.


Alright - thanks for the help :slight_smile:

We routinely send databases back and forth, so limit is at 300MB… so maybe I just need to slow my roll. 


Hi! I have tried the repair option but I still keep getting the error message. Any ideas?

As it is an IMAP or Exchange account, you could remove the account from eM Client, then add it again.

I had to delete my account then added it back. So far the error has not come up. So this may have fixed it.

Probably. If the error was caused by some corrupt cached data, removing the account will have flushed that data.