Contacts Not Showing in "Select Contact" List When Writing Email

I have an interesting issue. When I click “new” and then “To:” to choose recipients I don’t get the complete list of contacts to choose from. If I go to the contacts tab or use CTRL+B I get all the contacts, so they are there, but not all show up when I want to pick them for an email. If I use the auto-complete (by beginning to type them in the recipient bar) they are there.

I have checked that the “Select Contact” is set to search all contacts and that “local folders” is showing.

Email is hosted on GSuite.

I think I’ve been through all the options, but still can’t figure it out.

Windows 10 and latest version of eM Client.

Make sure you have selected “Contacts” under your Gsuite / Gmail account in eM Client.