Contacts, automatic "refresh" with Gmail and Google Apps?

I’m using emclient 4.0 with google apps and have found that it works very well except for one problem with contacts. Changes to Contacts do not automatically sync with Google, I have to manually click the “Refresh” icon.

I’ve searched the forum and found lots of posts regarding contact sync, but not any definitive answer. Can someone tell me if it is “supposed” to automatically sync contact changes, or if I have to manually click Refresh to get changes synced with contacts.

Is there any way to get it to happen automatically?

Thank you.

I am not sure what version of eM Client are you using, but it works on my PC properly. Wait until the version 5 is released and let me know if the problem reoccurs.

Thank you for the reply. I am using 4.0.15145.0. I have set up emclient for several others and all experience the same thing with the contacts not syncing with google apps automatically. I just use the “wizard” to setup a gmail account in emclient. Would there be any other setting that I would need to configure to get it to automatically sync with gmail contacts?

I will also check out version 5 when it is released, but wondering if there is anythiing that I may not be configuring properly on version 4 in the mean time.


could you please send me your logs? It would help us to analyze the problem.

  1. Open Tools - Settings - Logging, enable GData logging under the problematic account and try to simulate the issue. Then send the log directly to me using the same logging settings window. My address is

  2. Open Tools - Operations and copy the text from the tab Log. Send me this text along with your GData log.

Thank you.

Thank you for the reply. As I was preparing the logs, I believe I found my error. The contacts were not categorized “My Contacts”. Once I did this, then they all synced to Gmail automatically. Can you tell me if there is a setting that would make any new contacts that are created to automatically be in this category by default?

There is no setting for that. You have to expand the contact folder by clicking on the little arrow near its name, choose the folder/label My Contacts and enter the new entry here.