Contact "Display As:" problem and question.

I’ve been using eM Client for only about 1 month, and I’m very grateful for eM Client, very grateful. Does anyone know however, how to insure that when sending emails my name instead of my email address shows up. When I send an email to myself after placing my name alone in the Contact “Display As:” box and then test it, it always comes to me as an email address only. I’m wondering if that is how my emails show up when sent to other people? How do I get the “Display As:” to work by not showing my email address?
Thank You very much.
Phil

This setting is set at the menu -> Tools -> Accounts -> ‘the e-mail account you’re using’ -> General -> Name under user information.

The name you set there, would be the name it uses to send mail, instead of your -email address.

I have that set to my name but my email address only shows up as the sender and not my full name. Any help would be appreciated. Thanks.

Could you please send me an email at wilson@emclient.com? Thank you.