Connection Failed Error (GMail)

eM Client has suddenly started giving ‘Connection Failed’ error message when attempting to refresh emails from GMail. No settings have been changed in eM Client or GMail. Am using Version 9.2.2258 (7080479).
In trying to resolve this, I have tried the following:

  • Set up a new (test) account in eM Client successfully. All contacts were correctly loaded in eM Client from GMail Contacts, but emails gave the same error message.
  • Added a new contact in GMail which was updated in both accounts in eM Client.
  • Changed details of that new contact in GMail, which also was updated in both accounts in eM Client.
    Why is this error happening, only for emails & not for contacts?

An update on this issue…
Seems to be a conflict with Avast Antivirus. When I turn Avast off, the connection works OK.
It then fails again as soon as I turn it back on.
Anyone else having this problem? What is the solution?

Seems to be a conflict with Avast Antivirus

Avast and Avg both by default usually interfere with receiving mail unless you are very lucky.

Most users have to end up “disabling the mail shield” scanning part of the Avast or Avg program so it’s still running resident but not interfering with the mail client. “This is the easiest method to make it work”.

Alternatively contact Avast via their website or phone to see how to allow a mail client to still operate and not interfere. That involves “adding eM Client as an allowed program in Avast” and also “installing the exported Avast certificate into eM Client”, but no guarantee that will work 100% everytime as some users found due to the way Avast works.

Lastly if you have Windows 10, 11 they both have an excellent antivirus, malware, firewall built-in and don’t need any optional program installed.

Windows 10 Security Program Information

Windows 11 Security Program information

1 Like

Thanks for that advice - getting rid of Avast & using Windows Defender is certainly an option.
I have however found a solution - In Avast, add GMail as an ‘Exception’ to Mail Shield.
In Avast interface select Protection/Menu/Settings/Exceptions and add GMail URL to list of websites to be excluded from shield:

So far, this appears to be working.

1 Like

An update to previous comment…
This appeared to work for a while, but the same connection error has now returned.
So back to square one!

An update to previous comment…
This appeared to work for a while, but the same connection error has now returned.
So back to square one.

Yes I mentioned previously, adding eM Client as an allowed program and exporting Avast certificate into eM Client is no guarantee that it will always work 100% everytime due to the way Avast works.

The easiest solution if you want to use Avast is “just to disable the Mail shield” so it’s still still resident in memory & then doesn’t interfere with eM Client.

Alternatively as mentioned contact Avast and they may be able to assist you to make it work. I personally would just uninstall it & not use it.