compacting database from 44GB to less amount

I recently activated the “load attachement” option for my IMAP account but because synchronization considers all the folder on the server (no way to select part of them, other topinc), the database became very large: more than 40GB.
When I close the application, sometimes, the database is not closed correctly and at restart I’ve the cleanup process that takes time and more space on hard disk (about 40GB to recreate the database): it is time consuming and space consuming on a “small” hardisk.
Now, for test, I’ve deselected the option but I don’t know if it is or not possible to reduce size of this data base.

It is probably linked: When I move a message from my Office365 (i.e. exange) folders to IMAP folders it is very long. I hope reducing size of database may also help this.

After you have unselected to download for offline use, right-click on the Inbox (or whichever folder has these messages) and choose Properties > Repair. If it is a Gmail account, right-click on the All Mail folder instead.

See if that reduces the database size.

No changes after that repair. I’ll try again this afternoon, after restart of the PC.

Is there a simple method to identify which account corresponds to this large data base: I’ve an exange and an IMAP on my configuration.

Edit: Oups, I’ve seen in properties menu an identifier for the directory: my large database is really for IMAP account

I think maybe the only other option will be to remove the IMAP account from eM Client, then add it again.

restarted, same size, same status.
I’ll see with my colleague to remove and recreate IMAP account. It will be possible onyl end of August…

Thanks for your suggestions