Comcast.net SMTP mystery

For years, I’ve used eM Client 8 to connect to three comcast.net accounts using IMAP and SMTP. Recently, one or more of the connections failed, so I redid the setup, changed passwords, and got two of the accounts to work. I tried the same port and other settings with the third, primary Comcast account but always get authentication or other errors. Upgraded to eM Client 9, but that didn’t change the outcome. Spent a long time on a chat with Comcast and got no resolution. Even tried connecting to that one Comcast account with Outlook and that also failed during setup.

Seems like it’s a Comcast issue. Has anyone experienced this and know of a solution? Thanks.

Yes!!! I set up 2 new accounts with the free version to replace 2 inactive accounts. Seemed fine at
first, then I got message "Password Required - Auth -less secured Auth disable. I have comcast
emails. I’ve used the configurations given. Nothing works. I feel like it is a comcast issue also.
I can’t get them on the phone. I’ve been without any email, sending or receiving for days now.
I believe there is a simple solution. I need a miracle.

The solution is to go into your Comcast email account setup and check the box for Third Party Software Access. I don’t know why Comcast changed that setting on me on one of my three accounts, but restoring it solved the problem.

1 Like

I went to my Comcast email account set up and checked box for Third Party Software Access. Still not working.

Questions.
What do you use for incoming mail server? I tried imap.comcast.net and mail.comcast.net
What do you use for outgoing mail server? I tried smtp.comcast.net and mail.comcast.net
If pop3, incoming mail server? I tried pop3.comcast.net and mail.comcast.net
What port numbers do you use? I tried imap 993, Pop3 995, smtp 587 and 465
For user name and password, do you use Xfinity account user name and password?
What about Security Policy? SSL or dont use secure connection?

Any advice would be appreciated.

imap.comcast.net, port 143, force SSL
smtp.comcast.net, port 587, force SSL

Thanks, just tried that. Still not working